summaryrefslogtreecommitdiff
path: root/dev-python/oslo-concurrency
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-11 01:05:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-11 01:05:34 +0000
commit7ece7f3d3bcd0184dd8dfd6653464da80184963c (patch)
tree11ae8def15c0148aaf70c9bcfb86da05c82de6a1 /dev-python/oslo-concurrency
parent6a4408b9bbd9fe61dc0966f587db94081fa5f52b (diff)
gentoo auto-resync : 11:01:2024 - 01:05:34
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest2
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-5.3.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index 4b5189f6e3af..46555b90c623 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1,3 +1,5 @@
DIST oslo.concurrency-5.2.0.tar.gz 60052 BLAKE2B 9f45af8beaa5fc145963e3e12818325dff2a00178c3154a4cf7ce2950ca90d9771be590593cc195c2909930416501da1042768da9ba653c0126437bb518a338e SHA512 9f645aa611882e1b7218a7fbf65b54fef523d9cf067f894e9441c0a8de3ab80495ec8a167604412385edf12fc7a53b73ac0ef63e977889db7021dd5b93b0d72f
+DIST oslo.concurrency-5.3.0.tar.gz 60677 BLAKE2B 72af8a54bbea85e7564c5c04463e106e16ab1608f7ae8662b1e5db3cc07d07b0bd2531dedd9227d6823700c0e93e3c160afe7ddf27f6023715e62b787246fb64 SHA512 6f3adc558a7879ae05bfbfa30dfa4c687e5f1cd6385a6881b2e1647b116aab5816d1333b42bac0c8554685ea2ac3ee293d5b9dc836c214bb708e2d53a6971639
EBUILD oslo-concurrency-5.2.0.ebuild 1172 BLAKE2B d3f67320c6c381f73a4018b903b627f93e6b16f9f25a57534e1103f8312fd64f8c43a4be58e0ec758e9b6e45bb44b7d7612ffecb37d7a9c81b13f4c7c63b571a SHA512 11d0205289a5b254b8ffe1cba8f6eff6ddee6394b6a1e77c6f1732204b9172a7f774d2382f0ead9d96aab0aac38fbf5e696f167f87772f289f4762df179e29cb
+EBUILD oslo-concurrency-5.3.0.ebuild 1175 BLAKE2B 44b0e9b7764432e69da65508d166473313034c5dcdd3646b19508eaf928923f8073f7e0e44f3b9375b71cc3379c64d2971a58150485a8a617aa740222dc8bca6 SHA512 da9aadeba50a9165fef5dea1fdab25305ac724374bf41cec30eb642698a0fb0f2c56ab257298ea3b835dc77f2b42e5c8dd3478a58c07f41b6a8b3c71fba45766
MISC metadata.xml 423 BLAKE2B 965b9f3a9b25cd0f93f13bc12af982b8435e946c1317b6c3a013d016ac6ac3df39f94e1a69f6ef28355459cc5d59fa32c2004727e6772696dab755aee6ad46f4 SHA512 ffc8e1547e6f8356071744a4cf2d5f88d02f2a34322857245c68057699f0b87ea351a7821682ab3d72b777260c8887524467a201fe931787fa1b2ad67eb022a3
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-5.3.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-5.3.0.ebuild
new file mode 100644
index 000000000000..8706152fbfa1
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-5.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Concurrency library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.concurrency/
+ https://github.com/openstack/oslo.concurrency/
+ https://pypi.org/project/oslo.concurrency/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fails, then hangs
+ rm oslo_concurrency/tests/unit/test_lockutils_eventlet.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}