summaryrefslogtreecommitdiff
path: root/dev-python/oslo-concurrency
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-07 10:35:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-07 10:35:35 +0100
commita0e773d57146b0a0ec25567af504a10e6f187811 (patch)
tree09e8f87aa02b56f14f16e82522b625cfeccb1103 /dev-python/oslo-concurrency
parent1ccef27203b03f1fa900c9b44dc425df27e49452 (diff)
gentoo auto-resync : 07:09:2022 - 10:35:34
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest2
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-4.5.1.ebuild51
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index dfaf330eb3ad..66f0eb75d3c7 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1,5 +1,3 @@
-DIST oslo.concurrency-4.5.1.tar.gz 59126 BLAKE2B 61f509b4ce76cd036b695bb5ad744374e029239a63a629a4b96d44c8ba29150095fe9d57000367c4d07dc7c358ef61cfa4868a2347f206327093ad32ffb85955 SHA512 88319915c90befb01a275666b4a760357c1e72f04d5faf27ab9c67629ecbf2dd3a73d077f3c57435231b55aa777a9642f26e91cc4cb27ad56eb801b2b98eca48
DIST oslo.concurrency-5.0.0.tar.gz 59343 BLAKE2B 412fba38e0281b2c6d7b27182d159c99730a22ec3400586481f234998cd2f446de5cdd84aaa3abb1cdd93eb9eff1294c87ce51e165dc49caa078e69932ecd19b SHA512 570acbaf599a8a177ba6bc7c009edb43db5e077c06bee5c5895d81944daf78c8dde197bd9af730b17b5075fdaf527252aa44ea0edb79d73e16714582645afb7e
-EBUILD oslo-concurrency-4.5.1.ebuild 1289 BLAKE2B b622f95226eaa12059d70956621db39bebd6681bbd7809473ae97633e13eaf337e244ce923948903c4ae95a46a8b3a334e23f658ef1297858fe6c1c3ee62f742 SHA512 4516c8be42f0716c4992adc77be2dff98863edb93a0f9450cbe4a5da212fa98c3e3a2d4f88d706e0e7a1c11317d52a3b58df05a8b90f47b7b92ff98f97d9307c
EBUILD oslo-concurrency-5.0.0-r1.ebuild 1285 BLAKE2B 063aef3f21f12f0b6532d028d27e73739c54e5f481f5909536fc4235c7de243558eb21633d7fa203242d873d40e3be8f750a2fec88ff99a7ae86f171d90f6ff3 SHA512 648aa87693351426fb31348c3d5091f0325bc229478bb15f687f5848ab7a5b21df3ee7a663f3d5ea8c0c54b0bfbd659f924f190db50e2176c727d1a72ae9f3aa
MISC metadata.xml 423 BLAKE2B 965b9f3a9b25cd0f93f13bc12af982b8435e946c1317b6c3a013d016ac6ac3df39f94e1a69f6ef28355459cc5d59fa32c2004727e6772696dab755aee6ad46f4 SHA512 ffc8e1547e6f8356071744a4cf2d5f88d02f2a34322857245c68057699f0b87ea351a7821682ab3d72b777260c8887524467a201fe931787fa1b2ad67eb022a3
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-4.5.1.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-4.5.1.ebuild
deleted file mode 100644
index c2a8701d0d14..000000000000
--- a/dev-python/oslo-concurrency/oslo-concurrency-4.5.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Oslo Concurrency library"
-HOMEPAGE="https://pypi.org/project/oslo.concurrency/
- https://github.com/openstack/oslo.concurrency"
-SRC_URI="mirror://pypi/o/${PN/-/.}/${PN/-/.}-${PV}.tar.gz"
-S="${WORKDIR}/${PN/-/.}-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
- >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/eventlet-0.19.0[${PYTHON_USEDEP}]
- ' 3.8 3.9)
- )
-"
-
-distutils_enable_tests unittest
-
-python_compile() {
- distutils-r1_python_compile
- if ! has "${EPYTHON}" python3.{8..9}; then
- find "${BUILD_DIR}"/install -name '*eventlet*.py' -delete || die
- fi
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- eunittest
-}