summaryrefslogtreecommitdiff
path: root/dev-python/oslo-context/oslo-context-2.17.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
commit4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (patch)
treef7640b8b96a04499f1ce44a2cad122d45a8373bd /dev-python/oslo-context/oslo-context-2.17.0.ebuild
parent48bdeb0db9c7ffed22c6eb859ee40b55ba598b86 (diff)
gentoo resync : 21.12.2017
Diffstat (limited to 'dev-python/oslo-context/oslo-context-2.17.0.ebuild')
-rw-r--r--dev-python/oslo-context/oslo-context-2.17.0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/oslo-context/oslo-context-2.17.0.ebuild b/dev-python/oslo-context/oslo-context-2.17.0.ebuild
deleted file mode 100644
index 30395570fad4..000000000000
--- a/dev-python/oslo-context/oslo-context-2.17.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Helpers to maintain useful information about a request context"
-HOMEPAGE="https://pypi.python.org/pypi/oslo.context"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.11.0[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/positional-1.1.1[${PYTHON_USEDEP}]
-"
-
-S="${WORKDIR}/oslo.context-${PV}"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-# This time half the doc files are missing; Do you want them?
-python_test() {
- nosetests tests/ || die "test failed under ${EPYTHON}"
-}