summaryrefslogtreecommitdiff
path: root/dev-python/oslo-i18n
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
commit4935506e9a5cbfabd37c64093eac5f36c2ff0017 (patch)
treeaf9dd93ea349eacaf28286c7c45c7a083b0b7c31 /dev-python/oslo-i18n
parent434d713861b70f6c6563d6ee50a8e64f14c970d9 (diff)
gentoo resync : 17.02.2018
Diffstat (limited to 'dev-python/oslo-i18n')
-rw-r--r--dev-python/oslo-i18n/Manifest2
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/oslo-i18n/Manifest b/dev-python/oslo-i18n/Manifest
index d8cf20704e59..f502741f5f39 100644
--- a/dev-python/oslo-i18n/Manifest
+++ b/dev-python/oslo-i18n/Manifest
@@ -1,3 +1,5 @@
DIST oslo-i18n-3.17.1.tar.gz 42660 BLAKE2B 645a8341cf2bedf18932fbfa092b608da4169993a2a62aef36b869e975dfd662b7d52008aedf046b09ac10e4641e810902904b16e450a728b0f075fdee654977 SHA512 86d244eba7a887d4b8c3327487c9dd67c8e4baa52afdc05f94a229d6c1c951b8a25fc628f490320501773bb808afb8fb3b450a8d26e11b9a36a3c22baaa64544
+DIST oslo-i18n-3.19.0.tar.gz 41888 BLAKE2B 651b6e1ee2d2d6c11bd1b86b78eadf70b33338f5495fb93d58747635961df20fbf74fb2a949ef81b82efce582410f05c88806e678f688bb686b500378c77ff6e SHA512 2c12fc5ec24fbebd2624b3bf9d3043a62da84304e73a995c49b395e792bd9bd7d38a13f5e3086abe59bbb9ef43729a47eaee78ea0701ed05c15f5070af232a69
EBUILD oslo-i18n-3.17.1.ebuild 1944 BLAKE2B f50bccee49fa6c4182b8012918efa1c905e22716ccb9e7385043da9c10ecd2fd53c5c09e2530f1088a96283e8053b91ce74e457338da3412b0d8dacf371a3ac4 SHA512 f1a189771d993733f56b44985664bafe4f0db4a53d60c7c51b143f53aa8ff5b6f375e624a3860145945575975b465cfcd3adf412ad1635baba6e30464f54f0cc
+EBUILD oslo-i18n-3.19.0.ebuild 1757 BLAKE2B 48d70d025711cc2d8376395b2412e6608cad06029714b0a0849ddb6b9548ff49c43960a4a4d7e2e0317833a2bdd80a650ad21ac9c56a1a643ea9bde75e13c6d1 SHA512 d6247e4011e46ef3a7ac4bec529546de6d5a02f2e1a1dc30ae7b262aac05a9ec239ed6ee954d2f3bb5e882ff19517e16867c8b7804b8dbcdea402a1be85df785
MISC metadata.xml 472 BLAKE2B 98f7913442dadb92834bbc027d458b5abaeeac785c881d6a4c51cef401126795a70254373901b626908b2b513867e6b6f9c2254417473c48229bedadc572bf8c SHA512 cd798ff83761c7409f07974012b11443e52cff35588e610d0d047438834198e9a3e35c69a6f6e1f724e8b7a118dd4cc4eb8df38e6017caa22bc061d697c0e97f
diff --git a/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild b/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild
new file mode 100644
index 000000000000..b5bcdc237653
--- /dev/null
+++ b/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo i18n library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}