summaryrefslogtreecommitdiff
path: root/dev-python/oslo-i18n
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/oslo-i18n
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/oslo-i18n')
-rw-r--r--dev-python/oslo-i18n/Manifest4
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild2
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-3.23.1.ebuild71
3 files changed, 75 insertions, 2 deletions
diff --git a/dev-python/oslo-i18n/Manifest b/dev-python/oslo-i18n/Manifest
index d47aa8a12ce5..4840a9a81d7c 100644
--- a/dev-python/oslo-i18n/Manifest
+++ b/dev-python/oslo-i18n/Manifest
@@ -1,3 +1,5 @@
DIST oslo-i18n-3.19.0.tar.gz 41888 BLAKE2B 651b6e1ee2d2d6c11bd1b86b78eadf70b33338f5495fb93d58747635961df20fbf74fb2a949ef81b82efce582410f05c88806e678f688bb686b500378c77ff6e SHA512 2c12fc5ec24fbebd2624b3bf9d3043a62da84304e73a995c49b395e792bd9bd7d38a13f5e3086abe59bbb9ef43729a47eaee78ea0701ed05c15f5070af232a69
-EBUILD oslo-i18n-3.19.0.ebuild 1754 BLAKE2B 49dbdad35fde85dbb45aa6a120e656f760bc39c4f31951f6d1875a7e1ce1f4046647c7bdab7c3b460e2fbf98a7a08a1e6549527d6a83f1df6b1fa652d6cd5719 SHA512 2014b1b84fe050bf2f0bf64147b26e345c4fb27ff7ed40e1a81b66e94aa64826b3d7e4c767414f42ae75530cb06bdabb65eef7a1a2051f3ee3ea6aa2c2820abb
+DIST oslo-i18n-3.23.1.tar.gz 44731 BLAKE2B 2205d5f27640fe15c7143df2e18d27b01a3f90c30b04b838643d33cc490cc4257cde77925d76fefd0add0d3159ee4976281608b6e43288f0c0cd4fc4c7959b47 SHA512 82ebcf54d7edbd7c3e7c1d7e13b223ca9cf88aae717ee6fa0c2fb9b423ef88403b42b3360cfd7b8dd3b6d973a077a1458fc9c879efbb6006a1cedc6ade35397b
+EBUILD oslo-i18n-3.19.0.ebuild 1752 BLAKE2B 06318a1101e69cf38d6d90df5baf1ce74ba6870d3659b80e96797e7fa9d1c255f9e60a66fd941ebeb9442332d45da9a0e2e31dbddc6e340cb1c6964a5964395e SHA512 4e10a94048288b9e7fa39fc240c41a99bc994759d9eab0bceba47d609e40b758447ca363629cb2e9a7f3685a1de8931b97ef7da8e0850a2901b0a0a1a6050ee1
+EBUILD oslo-i18n-3.23.1.ebuild 1890 BLAKE2B b12c3d4c70bc291b094f88cc649114fbc508f60effe6f10209a630bca133bf861e63e5001dea9888d68859f9edaa1cbd1eeec6da7f07630680755efabae65908 SHA512 dcdaf60a2f526b5f82ca41fb89ca55945a4b65d6f3ef6dbbf5dc0f07cfff471618664c9befc17a0c2690611314297f66a0c604e64fe6644894cb62535ad498a6
MISC metadata.xml 365 BLAKE2B de17547743fb15cc3453fbff770a48a4f7d7222e6a5f437064eef2269ecbc0a8ba3723893d653074364afd320894fda16f4e2f70da3dc6f60bf5e2ac763d61d5 SHA512 c3f2d54fd641ba2c5f423e2d358ccd8001354a7a3dc405af89b781ed167340b8a1dc23b3c15e70d60b72ed2d35ced17f9d4e6c1442ba8b3f919ab1788b33db37
diff --git a/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild b/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild
index 61e91e31fe88..86c994244425 100644
--- a/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild
+++ b/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1 vcs-snapshot
diff --git a/dev-python/oslo-i18n/oslo-i18n-3.23.1.ebuild b/dev-python/oslo-i18n/oslo-i18n-3.23.1.ebuild
new file mode 100644
index 000000000000..23787714b286
--- /dev/null
+++ b/dev-python/oslo-i18n/oslo-i18n-3.23.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo i18n library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}