summaryrefslogtreecommitdiff
path: root/dev-python/oslo-rootwrap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/oslo-rootwrap
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/oslo-rootwrap')
-rw-r--r--dev-python/oslo-rootwrap/Manifest3
-rw-r--r--dev-python/oslo-rootwrap/metadata.xml18
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild48
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/oslo-rootwrap/Manifest b/dev-python/oslo-rootwrap/Manifest
new file mode 100644
index 000000000000..a00266eac3a2
--- /dev/null
+++ b/dev-python/oslo-rootwrap/Manifest
@@ -0,0 +1,3 @@
+DIST oslo.rootwrap-5.13.0.tar.gz 43433 BLAKE2B 8d53587f63022255683d18b8ce22dca07a160d7692e9d2fcd5e6c466bb6969da11a9a1af4646809921724b9f1b63b2532728bd3ade82312354793b6b4d15f0d4 SHA512 ff716e1e5900f754617578eb8bf60c1d2794474706f22a0c619c94177602ed3c3acde42ad499a7a613f310d6dffe526339b5cd1c96ecc727dcc43e1a9afd606c
+EBUILD oslo-rootwrap-5.13.0.ebuild 1616 BLAKE2B a25585dca831c504dc21f48107d48245e16f79e965ce17e533cdcc18219d383046d67733811753551e4813630b3fc572ac8554bf2fd2804e7bd4665bbb1f0881 SHA512 042f7a216148ce36b0000c0bf2254f1aa255ebaa67ec0281114b82b94f0fb93f5b1d656ddeb1d6ff9be8a5934e28db44f5b43deb8feff3dee1ce46bad00ac56f
+MISC metadata.xml 600 BLAKE2B 93dce16794b8495f34be98af703ca0ba06ff4a2e378805f7f3b08d4805f01ad015a1144124e1ad32eb63e6b5c9a9378aea30a4b82eeab54b1cb9dc95280fc6fd SHA512 ad1012d9f43875065679837f787f6a8087876d4ef1e56d24fcd2aa379c85e628848dcf5fa03e84e5929cdfabc4c1b6e2f7167ac0a508f7f26b6b533405932e10
diff --git a/dev-python/oslo-rootwrap/metadata.xml b/dev-python/oslo-rootwrap/metadata.xml
new file mode 100644
index 000000000000..1007566efb08
--- /dev/null
+++ b/dev-python/oslo-rootwrap/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Oslo Rootwrap allows fine filtering of shell commands to run as root from OpenStack services.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">oslo.rootwrap</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild
new file mode 100644
index 000000000000..48ee97f9e724
--- /dev/null
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
+HOMEPAGE="https://pypi.org/project/oslo.config/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
+S="${WORKDIR}/oslo.rootwrap-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}