summaryrefslogtreecommitdiff
path: root/dev-python/oslo-rootwrap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-python/oslo-rootwrap
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-python/oslo-rootwrap')
-rw-r--r--dev-python/oslo-rootwrap/Manifest2
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/oslo-rootwrap/Manifest b/dev-python/oslo-rootwrap/Manifest
index b54768435420..ae9173ffbf35 100644
--- a/dev-python/oslo-rootwrap/Manifest
+++ b/dev-python/oslo-rootwrap/Manifest
@@ -1,3 +1,5 @@
+DIST oslo.rootwrap-5.13.0.tar.gz 43433 BLAKE2B 8d53587f63022255683d18b8ce22dca07a160d7692e9d2fcd5e6c466bb6969da11a9a1af4646809921724b9f1b63b2532728bd3ade82312354793b6b4d15f0d4 SHA512 ff716e1e5900f754617578eb8bf60c1d2794474706f22a0c619c94177602ed3c3acde42ad499a7a613f310d6dffe526339b5cd1c96ecc727dcc43e1a9afd606c
DIST oslo.rootwrap-5.9.2.tar.gz 43716 BLAKE2B 4e455fe52c6f20824bf220a8444dfcdc916dfd85f0ff42edf8e3a6b8a065a45344122f56272943cc06f88fc272522af9914dd2a961d3c98c30ba66741419aa1e SHA512 3ad7c2d028c3052476bc26c00bf34c421b44db59cae2d45b5d1041902c14227f6de89a9b8fb36f123c9a9e477dcee42e567425439d9d3eb12a5f701c5a13be6b
+EBUILD oslo-rootwrap-5.13.0.ebuild 1625 BLAKE2B 50ecdc2aeb0a79a1c0ba444b413e4f6d6a14d8a83940667a7ac05e131c1db2b7f69a257880cc6f55638eabd616ce0df1ec08f636f54fecdc91803f59b434ac3a SHA512 472a1679af4f11b524b0c44a8ab0228410b06ab6e1c805e370bf7a960bf525e922d611d59dacaf2c0a29151ba0455d80d875cccafe91361d3aa19387e2fc7bc9
EBUILD oslo-rootwrap-5.9.2.ebuild 1669 BLAKE2B 53d58d7ca0a805c8135b2c838cc0df32a2b505c02831d6a386b7809159528fe098f6afc69ec96c06af513a8004b2e811730734e6874c29f6284dc146414aa430 SHA512 319d8a02de07d5a621a0945b08db483ad8d01b81cce61171f6cd816ec15bc52f3e6bbac203b4145835f08073a792534861db938ad7ef6f44830ca41f01cc38c9
MISC metadata.xml 600 BLAKE2B 93dce16794b8495f34be98af703ca0ba06ff4a2e378805f7f3b08d4805f01ad015a1144124e1ad32eb63e6b5c9a9378aea30a4b82eeab54b1cb9dc95280fc6fd SHA512 ad1012d9f43875065679837f787f6a8087876d4ef1e56d24fcd2aa379c85e628848dcf5fa03e84e5929cdfabc4c1b6e2f7167ac0a508f7f26b6b533405932e10
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild
new file mode 100644
index 000000000000..3d47240431fc
--- /dev/null
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
+S="${WORKDIR}/oslo.rootwrap-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}