summaryrefslogtreecommitdiff
path: root/dev-python/outcome
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/outcome
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/outcome')
-rw-r--r--dev-python/outcome/Manifest3
-rw-r--r--dev-python/outcome/outcome-1.1.0-r1.ebuild37
-rw-r--r--dev-python/outcome/outcome-1.1.0.ebuild18
3 files changed, 50 insertions, 8 deletions
diff --git a/dev-python/outcome/Manifest b/dev-python/outcome/Manifest
index 73a9ce08c95b..770f86b753c1 100644
--- a/dev-python/outcome/Manifest
+++ b/dev-python/outcome/Manifest
@@ -1,3 +1,4 @@
DIST outcome-1.1.0.tar.gz 18675 BLAKE2B eef22274bb4d1ddd19fa223167b6c8ce96f015ac0b3b0609aed3717deb306087457ab068fd2466d492fcc5859d561e6d3172ad14611a937ec59a75b604565953 SHA512 65de1c0a38b8cbb041a9fc3a79518eeacea54ec87341846ae80a9a2075369f72a397f5aa747ae179eaac8f341a7e07cc1641555fbb809cc7924b2171f7f3d90e
-EBUILD outcome-1.1.0.ebuild 762 BLAKE2B 514a40b5b28baaae33f55cf985ba493b1306a1a0666b1920a1f5b2d0e629490b0b5bf0ecb2fc55f1364166b4939a7ab152d8ffc91b64f08cc51dddd5829e4367 SHA512 6791e15dd493ad592d43ea8d63bcbe1625e0cc76dbe22035b6ba4961661add073e3721d1b832ebef36b46d68418d6aac340b9fedf75d554014c145b74de0dd74
+EBUILD outcome-1.1.0-r1.ebuild 822 BLAKE2B 7d39fb1354c81c74263d2d75e0079766177d2eeb862f48918499fc30927d07e73cd1d05b977da223a771f0d0ff2714cb59599de2b03b090891a20ea121011f7f SHA512 1cd0c51b7e1859111c461dd4a06d5c457faa0287aceaab349f78820f30e38ed1aac445d544a4f640e70eacb355d989b5bac2b5808d8c469b3600169a9fe7f3d1
+EBUILD outcome-1.1.0.ebuild 777 BLAKE2B cf2dbdeb7aa6c9db4e9e87733533235c0ff5357d949582c03f85ecaaa05e35aa7777406a692e9c9104c19e7171ab5e62a7a0a6ee95c9a5995dd87dd0bdf33fba SHA512 d435bef3694e0b2593a628a56a3c258c4e9ce9d079cbe8cc228dfa8856c12ce33065ccde3e2bda4f5f85428ff51d19e340351971abf45ebd86982fdf2772189a
MISC metadata.xml 413 BLAKE2B 375ed97b3bcb2ba5392f09962f6376e5ec8ecb842a70eb8c94647968f2f59e326ddacba74f0e65b7bb5733a05779d464b38d589f3a3dd364ba510bec2825eb5c SHA512 b9b9b94031580858aae25d0733688ce39f5026b4c1a59415370ed50dc27b63654927c36536d4c4cdf6389e68db0b397ddaa7e0aeb786713fdffca4bddaa217d2
diff --git a/dev-python/outcome/outcome-1.1.0-r1.ebuild b/dev-python/outcome/outcome-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..8da627573eeb
--- /dev/null
+++ b/dev-python/outcome/outcome-1.1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Capture the outcome of Python function calls"
+HOMEPAGE="
+ https://github.com/python-trio/outcome
+ https://pypi.org/project/outcome
+"
+SRC_URI="
+ https://github.com/python-trio/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source dev-python/sphinxcontrib-trio
diff --git a/dev-python/outcome/outcome-1.1.0.ebuild b/dev-python/outcome/outcome-1.1.0.ebuild
index 9f4c94e538b5..722e60e24ead 100644
--- a/dev-python/outcome/outcome-1.1.0.ebuild
+++ b/dev-python/outcome/outcome-1.1.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
@@ -18,12 +18,16 @@ LICENSE="|| ( Apache-2.0 MIT )"
SLOT="0"
KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-RDEPEND="dev-python/attrs[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+"
-BDEPEND="test? (
- dev-python/async_generator[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
-)"
+BDEPEND="
+ test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
distutils_enable_sphinx docs/source dev-python/sphinxcontrib-trio