summaryrefslogtreecommitdiff
path: root/dev-python/pandas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-07 13:16:39 +0100
commite91a1aaa5ec8fab37f0fd082ac6024d41c6651e2 (patch)
treeee7587dfd365faadd9b297d595c31368bf94f9ca /dev-python/pandas
parent2d446203bcf1a0db08e99abca43513d246dfa73d (diff)
gentoo resync : 07.04.2018
Diffstat (limited to 'dev-python/pandas')
-rw-r--r--dev-python/pandas/Manifest2
-rw-r--r--dev-python/pandas/pandas-9999.ebuild59
2 files changed, 34 insertions, 27 deletions
diff --git a/dev-python/pandas/Manifest b/dev-python/pandas/Manifest
index 6bd001491df7..773fe1b5b200 100644
--- a/dev-python/pandas/Manifest
+++ b/dev-python/pandas/Manifest
@@ -13,5 +13,5 @@ EBUILD pandas-0.17.1.ebuild 5955 BLAKE2B d6a2126678d1c93d16346c7a83425810eb11853
EBUILD pandas-0.19.1.ebuild 5913 BLAKE2B 994e9ea3397d2dacb0a01ad17c8285cae39a898c5615b42598f0a85745a74b4c01a2968da343a969160f18658fdae8cc6e6f0288f7254189d6233a4e16b21923 SHA512 6e88582440d02ad3adf338692082ff671c0c4f93f56adb029abfa5dea7210de30308371f990e4b2bbcdfbd510040e40c18a373123a862099d779993f81dda714
EBUILD pandas-0.20.1.ebuild 5846 BLAKE2B b6abf38026c04a904b40d130c039c4395fd0bbd51aeb584a72428a26afddccb90198e6e02469eaa3942f6f76b95bdd6e9b53f433cfd5fd7715de9729ea35fb41 SHA512 9bb42445edb8f4dc62df830e30b8ea2e0856bf214f0621d7cbecebd2adc142bc2a4031e162e9ff93daf5f600d9e405386a32dca515fa6433f91e962c8ae00c37
EBUILD pandas-0.20.3.ebuild 5759 BLAKE2B 59d904b1b8ca18a0baf2f58340a0b24cf1e99bee4a40a51530ec9fc79eac2fa093a05aedcb7f0e268d06a1828a013736679d26594ba443e1ad763d69c062f29b SHA512 fe6f54a082a50d4ab3edb16c9b2f11cae1440027b06e35b539133b76584c9ae615fa9f72a70328df26de7012c67d250574e47ec0b443eb84e480792b6743846b
-EBUILD pandas-9999.ebuild 5830 BLAKE2B ff035f3603bb43b5695b29264dba0883a95c8a9adb811be386d70ecdd44988b0ea90e34436654acb03091217582a21bc949436b7767bdcba90dff53417c753b9 SHA512 b3bacfba75d58b10f0e4861ed7df8127af02ad4b65c71af58a5b68f43df23b0cb9c0646a720edd9f1dbdcc1a7fc59bbfd7d086428cc8e4439b46de24acfc18d7
+EBUILD pandas-9999.ebuild 5824 BLAKE2B adee94b3e8a50e86a21ef64b75650ae372d7b9d9be888519fdf4769e6fe3d6e4425e5c325685f820b8d7599addc39e260d6b138080b40f9e275586dae9a3a096 SHA512 043c913888f3290c2bc651de252ac73d8ea9c9061a72781f747d291f46a3f8dd4b760ef2449f61b5249a79293dcad6ca389b11608e0431c6324c9e1adde1a189
MISC metadata.xml 1077 BLAKE2B e9bfcfb9fc1baf813931a3cd0829136cdeb0a52a3a34a0d0ba28fbad6d4c3ebee24f1e5624d5242541fd14f4c435830b68ea30eab03d796e497116bdff732c77 SHA512 60b23a75873ded48dd01a36dae62f45f1cf5d044b88b125bda249fd6cf558ddef42d6677218053ed9d73de31da54f1f85bd1f64eab9b377f1a8b51fe1c510308
diff --git a/dev-python/pandas/pandas-9999.ebuild b/dev-python/pandas/pandas-9999.ebuild
index c29b323ee1ac..6bf3185ad30c 100644
--- a/dev-python/pandas/pandas-9999.ebuild
+++ b/dev-python/pandas/pandas-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
PYTHON_REQ_USE="threads(+)"
VIRTUALX_REQUIRED="manual"
@@ -18,40 +18,41 @@ EGIT_REPO_URI="https://github.com/pydata/pandas.git"
SLOT="0"
LICENSE="BSD"
KEYWORDS=""
-IUSE="doc -minimal full-support test X"
+IUSE="doc full-support minimal test X"
-MINIMAL_DEPEND="
- >dev-python/numpy-1.7[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- !<dev-python/numexpr-2.1[${PYTHON_USEDEP}]
- !~dev-python/openpyxl-1.9.0[${PYTHON_USEDEP}]"
RECOMMENDED_DEPEND="
dev-python/bottleneck[${PYTHON_USEDEP}]
- >=dev-python/numexpr-2.1[${PYTHON_USEDEP}]"
+ >=dev-python/numexpr-2.1[${PYTHON_USEDEP}]
+"
OPTIONAL_DEPEND="
dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
dev-python/blosc[${PYTHON_USEDEP}]
dev-python/boto[${PYTHON_USEDEP}]
>=dev-python/google-api-python-client-1.2.0[$(python_gen_usedep python2_7 pypy)]
- || ( dev-python/html5lib[${PYTHON_USEDEP}] dev-python/lxml[${PYTHON_USEDEP}] )
+ || (
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
dev-python/httplib2[${PYTHON_USEDEP}]
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
- || ( >=dev-python/openpyxl-1.6.1[${PYTHON_USEDEP}] dev-python/xlsxwriter[${PYTHON_USEDEP}] )
+ || (
+ >=dev-python/openpyxl-1.6.1[${PYTHON_USEDEP}]
+ dev-python/xlsxwriter[${PYTHON_USEDEP}]
+ )
>=dev-python/pytables-3.2.1[${PYTHON_USEDEP}]
dev-python/python-gflags[$(python_gen_usedep python2_7 pypy)]
dev-python/rpy[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/statsmodels[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-0.8.1[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
dev-python/xlrd[${PYTHON_USEDEP}]
dev-python/xlwt[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
X? (
|| (
- dev-python/PyQt4[${PYTHON_USEDEP}]
- dev-python/pyside[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
dev-python/pygtk[$(python_gen_usedep python2_7)]
)
|| (
@@ -59,13 +60,18 @@ OPTIONAL_DEPEND="
x11-misc/xsel
)
)
- "
-
-DEPEND="${MINIMAL_DEPEND}
+"
+COMMON_DEPEND="
+ >dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/cython-0.23[${PYTHON_USEDEP}]
doc? (
${VIRTUALX_DEPEND}
+ app-text/pandoc
dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
@@ -91,23 +97,24 @@ DEPEND="${MINIMAL_DEPEND}
dev-python/psycopg:2[${PYTHON_USEDEP}]
x11-misc/xclip
x11-misc/xsel
- )"
+ )
+"
# dev-python/statsmodels invokes a circular dep
# hence rm from doc? ( ), again
-RDEPEND="
- ${MINIMAL_DEPEND}
+RDEPEND="${COMMON_DEPEND}
+ !<dev-python/numexpr-2.1[${PYTHON_USEDEP}]
+ !~dev-python/openpyxl-1.9.0[${PYTHON_USEDEP}]
!minimal? ( ${RECOMMENDED_DEPEND} )
- full-support? ( ${OPTIONAL_DEPEND} )"
+ full-support? ( ${OPTIONAL_DEPEND} )
+"
python_prepare_all() {
# Prevent un-needed download during build
- sed \
- -e "/^ 'sphinx.ext.intersphinx',/d" \
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" \
-i doc/source/conf.py || die
# https://github.com/pydata/pandas/issues/11299
- sed \
- -e 's:testOdArray:disable:g' \
+ sed -e 's:testOdArray:disable:g' \
-i pandas/tests/io/json/test_ujson.py || die
distutils-r1_python_prepare_all
@@ -159,5 +166,5 @@ pkg_postinst() {
optfeature "Needed for parts of pandas.stats" dev-python/statsmodels
optfeature "SQL database support" ">=dev-python/sqlalchemy-0.8.1"
optfeature "miscellaneous statistical functions" sci-libs/scipy
- optfeature "necessary to use pandas.io.clipboard.read_clipboard support" dev-python/PyQt4 dev-python/pyside dev-python/pygtk x11-misc/xclip x11-misc/xsel
+ optfeature "necessary to use pandas.io.clipboard.read_clipboard support" dev-python/PyQt5 dev-python/pygtk x11-misc/xclip x11-misc/xsel
}