summaryrefslogtreecommitdiff
path: root/dev-python/parameterized
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-28 17:13:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-28 17:13:02 +0100
commit670fe3b64a21a723fda1e52fe61cad2327f81f67 (patch)
treee6699a97f6776ef2588129c3ad5b895621d4e4aa /dev-python/parameterized
parent7aa28e7310855bc5ef0d32b22e8b58eec55c28c9 (diff)
gentoo auto-resync : 28:04:2023 - 17:13:02
Diffstat (limited to 'dev-python/parameterized')
-rw-r--r--dev-python/parameterized/Manifest5
-rw-r--r--dev-python/parameterized/files/parameterized-0.8.1-nose-to-pytest.patch101
-rw-r--r--dev-python/parameterized/parameterized-0.8.1-r2.ebuild35
-rw-r--r--dev-python/parameterized/parameterized-0.9.0.ebuild2
4 files changed, 2 insertions, 141 deletions
diff --git a/dev-python/parameterized/Manifest b/dev-python/parameterized/Manifest
index 9da28a67b192..b063941350d2 100644
--- a/dev-python/parameterized/Manifest
+++ b/dev-python/parameterized/Manifest
@@ -1,6 +1,3 @@
-AUX parameterized-0.8.1-nose-to-pytest.patch 3745 BLAKE2B 739bc6c813254e3616ffa3b7fb5c057cac41df1b9d8b076a0fb570d6908e7bd740f90875add4ab6bd265f60087a396434b8641bdc75e5108afc1c790d852132d SHA512 e7e65482f15f5fb3cfba9d7dd3f66755919ab6bf7464812cfa8636bfe0c0d409576d05a0d0e7ada79e4aa1c595507b0b7c12ad13c211b9f8decb7bccfc24833f
-DIST parameterized-0.8.1.tar.gz 23936 BLAKE2B 3d36b049071907f66ef17dcae0ef9480210344f2466744b2bee8e964f46e2553411a07b233fab032d1acbc2523dc32890bc5e6e4ffc5b37d1fee3f0db3a70cbb SHA512 ad6e31b2bb27623bf070ee5c30686a5bd6a531bc71602f77ca6aa01a77fc246caaacca121098dcbe13b1a174cdcfafa6545bf6e62f6a5337a647821c02fac64a
DIST parameterized-0.9.0.tar.gz 24351 BLAKE2B 3b0fb1c0a788f702cba74b67868fbd179e4912b518646f6a7d0d136f54b515d2546d27ad1fd14a03c128a8b53d42165a4ef9f8f434965483af24f69c3e406b25 SHA512 2c1c97a841db631608e0a9fcd93fa1af819aa288538851e0c771b56ba0bb27fb682ac3a09fcdb33e57162926d1e8fae452f7bab9384d0c40bec9a03ab3d6b126
-EBUILD parameterized-0.8.1-r2.ebuild 694 BLAKE2B b262bca540abfd2691cba6bc76bd768d32ff031fc02c5ca9ccd39a1e018ddb00308f68629da0db3ee57a0b35a8a04a4637843b97f476d7bd02000259890e79fb SHA512 bf8d8b615aeff39c5ae79710f539cb08b503d95328f76b377e791e28b3b65dc4138b18d5f43d40504a3cd23d53ce9a0166bbd78ca2a0189fe0fc499f06f4a3eb
-EBUILD parameterized-0.9.0.ebuild 600 BLAKE2B d1deaedaef7b84e4bf292abcf6d92d192a61d66f1a3aa9f77b933ebaa96b50e6dc9783ba33a0140b8954480e7392dc06d3510a50b788ba7ab066b26dfcd1075e SHA512 f64172c5f34bd0b549d3e4f1362a9844f673962ea76280853c81deb7b95b7f341b25724c69ec5f8e1ba2ae195f898d3d1e79cd1ceacf4e42d3c0282319e5409a
+EBUILD parameterized-0.9.0.ebuild 592 BLAKE2B f90018d1fb335080879497f67f1d9cc3c353496d81d8628dd0b03ea8546536c473f0e458d18824a374b4c7bcccb75974fce7ddde7ecd4b8f58777088ca70a709 SHA512 18c973c95bbaaaaf4ec3a3dafe9c3a3bd85ed7aef6d68b08303ef39318177101ca5aa80bbadf0e5f9f191e8096534623df8409a1f3edd7c350bc9df04795da07
MISC metadata.xml 480 BLAKE2B 95327992f9b6e7a46cea990d05d1e8b71dc65ce6f3da83cba142dc5190953c79b9932e3e295e6423687b86e8f564a0823acb7d05ed01d04c5d7a1bafc19ce304 SHA512 7717494be66e427dcdbbcc88d87abe2efe84198edae7bb281ad47390641dc66fbc42aa7af6dfe7061fe0dd1ef928da5ef882449dea1ce6e156403dd16dd82aea
diff --git a/dev-python/parameterized/files/parameterized-0.8.1-nose-to-pytest.patch b/dev-python/parameterized/files/parameterized-0.8.1-nose-to-pytest.patch
deleted file mode 100644
index 45b86d8a13af..000000000000
--- a/dev-python/parameterized/files/parameterized-0.8.1-nose-to-pytest.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-diff --git a/parameterized/test.py b/parameterized/test.py
-index f98d865..ede7689 100644
---- a/parameterized/test.py
-+++ b/parameterized/test.py
-@@ -2,8 +2,8 @@
-
- import inspect
- import mock
-+import pytest
- from unittest import TestCase
--from nose.tools import assert_equal, assert_raises
-
- from .parameterized import (
- PY3, PY2, parameterized, param, parameterized_argument_value_pairs,
-@@ -91,7 +91,7 @@ if not PYTEST:
-
- @parameterized([(1, ), (2, )])
- def test_setup(self, count, *a):
-- assert_equal(self.actual_order, "setup %s" %(count, ))
-+ assert self.actual_order == "setup %s" %(count, )
- missing_tests.remove("test_setup(%s)" %(self.actual_order, ))
-
-
-@@ -235,9 +235,9 @@ class TestParamerizedOnTestCase(TestCase):
- frame_locals = frame[0].f_locals
- nose_test_method_name = frame_locals['a'][0]._testMethodName
- expected_name = "test_on_TestCase2_custom_name_" + str(foo)
-- assert_equal(nose_test_method_name, expected_name,
-- "Test Method name '%s' did not get customized to expected: '%s'" %
-- (nose_test_method_name, expected_name))
-+ assert nose_test_method_name == expected_name, \
-+ "Test Method name '%s' did not get customized to expected: '%s'" % \
-+ (nose_test_method_name, expected_name)
- missing_tests.remove("%s(%r, bar=%r)" %(expected_name, foo, bar))
-
-
-@@ -259,7 +259,7 @@ class TestParameterizedExpandDocstring(TestCase):
- actual_docstring = test_method.__doc__
- if rstrip:
- actual_docstring = actual_docstring.rstrip()
-- assert_equal(actual_docstring, expected_docstring)
-+ assert actual_docstring == expected_docstring
-
- @parameterized.expand([param("foo")],
- doc_func=lambda f, n, p: "stuff")
-@@ -335,7 +335,7 @@ def test_helpful_error_on_empty_iterable_input():
-
- def test_skip_test_on_empty_iterable():
- func = parameterized([], skip_on_empty=True)(lambda: None)
-- assert_raises(SkipTest, func)
-+ pytest.raises(SkipTest, func)
-
-
- def test_helpful_error_on_empty_iterable_input_expand():
-@@ -366,10 +366,6 @@ def test_helpful_error_on_non_iterable_input():
- raise AssertionError("Expected exception not raised")
-
-
--def tearDownModule():
-- missing = sorted(list(missing_tests))
-- assert_equal(missing, [])
--
- def test_old_style_classes():
- if PY3:
- raise SkipTest("Py3 doesn't have old-style classes")
-@@ -418,7 +414,7 @@ class TestOldStyleClass:
- def test_parameterized_argument_value_pairs(func_params, p, expected):
- helper = eval("lambda %s: None" %(func_params, ))
- actual = parameterized_argument_value_pairs(helper, p)
-- assert_equal(actual, expected)
-+ assert actual == expected
-
-
- @parameterized([
-@@ -428,7 +424,7 @@ def test_parameterized_argument_value_pairs(func_params, p, expected):
- (123456789, "12...89", 4),
- ])
- def test_short_repr(input, expected, n=6):
-- assert_equal(short_repr(input, n=n), expected)
-+ assert short_repr(input, n=n) == expected
-
- @parameterized([
- ("foo", ),
-@@ -442,7 +438,7 @@ cases_over_10 = [(i, i+1) for i in range(11)]
-
- @parameterized(cases_over_10)
- def test_cases_over_10(input, expected):
-- assert_equal(input, expected-1)
-+ assert input == expected-1
-
-
- @parameterized_class(("a", "b", "c"), [
-@@ -461,7 +457,7 @@ class TestParameterizedClass(TestCase):
-
- def _assertions(self, test_name):
- assert hasattr(self, "a")
-- assert_equal(self.b + self.c, 3)
-+ assert self.b + self.c == 3
- missing_tests.remove("%s:%s(%r, %r, %r)" %(
- self.__class__.__name__,
- test_name,
diff --git a/dev-python/parameterized/parameterized-0.8.1-r2.ebuild b/dev-python/parameterized/parameterized-0.8.1-r2.ebuild
deleted file mode 100644
index dfdd966aed8f..000000000000
--- a/dev-python/parameterized/parameterized-0.8.1-r2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Parameterized testing with any Python test framework"
-HOMEPAGE="
- https://github.com/wolever/parameterized/
- https://pypi.org/project/parameterized/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-nose-to-pytest.patch"
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- epytest parameterized/test.py
-}
diff --git a/dev-python/parameterized/parameterized-0.9.0.ebuild b/dev-python/parameterized/parameterized-0.9.0.ebuild
index 83ca7c451ccd..cdcdc7bff151 100644
--- a/dev-python/parameterized/parameterized-0.9.0.ebuild
+++ b/dev-python/parameterized/parameterized-0.9.0.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
BDEPEND="
test? (