summaryrefslogtreecommitdiff
path: root/dev-python/paramiko
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/paramiko
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/paramiko')
-rw-r--r--dev-python/paramiko/Manifest2
-rw-r--r--dev-python/paramiko/paramiko-2.7.2.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/paramiko/Manifest b/dev-python/paramiko/Manifest
index 6d24b14fbfa3..a6fe5653ef32 100644
--- a/dev-python/paramiko/Manifest
+++ b/dev-python/paramiko/Manifest
@@ -1,5 +1,7 @@
AUX paramiko-2.4.2-disable-server.patch 1596 BLAKE2B 7e2ef1e216f34086c06d985556dde82eccfc08b835a9b336f1e54e81ddf32567872daec9dadc728bfaab8e3c4728439d704d51f9b1df5e04a64b5064f6d79bf5 SHA512 5e2f9285ffa3ece551ce929c6d50691761da6269e906355bbf79b0664a764083f7d55a9e347e2ed236a4c9a7f934d489315b68ebea984694ee9d1714416d34fd
AUX paramiko-2.7.1-tests.patch 4618 BLAKE2B 9c1d055e24e360574fdcb63ef01a1669e380da42aa2ca72ba158159a1d618b447936a3c3f746625126a1bf8c945d8000bd09aabc5918d25b3840296b57bb5469 SHA512 6192dadd31c33ccf178cd813b726c5c2cc31a12ac7698377ede19d10b19b4e32b6e203ec2bbf26b486f58151f642c4d44095e9efeabad96e2751fa4631ee11c4
DIST paramiko-2.7.1.tar.gz 330391 BLAKE2B 0f7a2f3b6c15a68002001d69f8402deea5421a8b1f6cf35061a8a36f4b81b7a291d7b0f0b457f32de4c4769659a2e067f0bdb6cc5dcdd0810ebf917e349e85af SHA512 2cebed2420cf9af77cb0d459b64a74adcffcdb15bd58c8fc9243855ae91f43e16706665b64ce2851f6e99e59ca6a47d7299a2aae35a4c9d01ab97b343569c4b2
+DIST paramiko-2.7.2.tar.gz 331678 BLAKE2B ff96dfd7b114255c15282f4f73e1f9425ccf77106426ccf3ad3f833b56bd5abfde867cf2d322448dc7b3777af6ab080b4e37ff8871ce17f0db17634b7f101747 SHA512 c9bc569428a0a61814cb73941356de5bae7fea7891ba4fd3f5c00ff1ee5083454bfde7e969fb4aaf5254b909f7f0132f590d67803eda8a67503e5c02ec2bf01a
EBUILD paramiko-2.7.1.ebuild 1333 BLAKE2B 93de0faeea4ad477a36f05460bc6a477574580cfae2d91cb70a9b6b1d39a007a3304b15084db1498dd300f0bb647d3ccd2d04fd0080d79349e8819fce6d14849 SHA512 64d03a22accc103508a3fb98711c5c257d18274f25a212153fc73a8b3d92e6e3880238c930f114fae2eb30fa9fbce7f2af50e427f80c91998189e7629c91b797
+EBUILD paramiko-2.7.2.ebuild 1348 BLAKE2B 4e6c97e7f2a53b8fcf628e424f7de31dda1d65713eab61b9648256693a3793e192e224010b31ff8871b98eaffcc8aec6d53caa57b241676752243231127758dc SHA512 3bc8a986434287b61080ede14f28cfd20fc3849c145eb4e5b45a0837fbe4e5e548ba14f478339cae5c265e0b95c0358f2e28f7a7affb0504e190261499775961
MISC metadata.xml 1331 BLAKE2B 4e53a314a1a86c488328a89170e03932bab1944bb133cd8551333da5a4cb80600e1bd5238b858bdc3565334cbc7251782979f4a770b43d064a9bb5096fdec7d7 SHA512 14cad597d85d0778ee8b2ce5c7cdda768e8f3cfb8de084189e7d0b422b77c73c2410448c8c013c1f03864e7b4365a87c1bba16fe49081f728c3bfef3d0ba455a
diff --git a/dev-python/paramiko/paramiko-2.7.2.ebuild b/dev-python/paramiko/paramiko-2.7.2.ebuild
new file mode 100644
index 000000000000..237c4965f4d0
--- /dev/null
+++ b/dev-python/paramiko/paramiko-2.7.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="SSH2 protocol library"
+HOMEPAGE="https://www.paramiko.org/ https://github.com/paramiko/paramiko/ https://pypi.org/project/paramiko/"
+# pypi tarballs are missing test data
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris"
+IUSE="examples server"
+
+RDEPEND="
+ >=dev-python/bcrypt-3.1.3[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.5[${PYTHON_USEDEP}]
+ >=dev-python/pynacl-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx sites/docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-2.7.1-tests.patch"
+
+ if ! use server; then
+ eapply "${FILESDIR}/${PN}-2.4.2-disable-server.patch"
+ fi
+
+ eapply_user
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r demos/*
+ fi
+}