summaryrefslogtreecommitdiff
path: root/dev-python/parso
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
commit9323524b4d44f4ec3dc923bd8e9ea04bdde8a067 (patch)
tree8ca7b8c58d4e70389d5d4672ebd86cb475cf9f80 /dev-python/parso
parent8c11cf748cc296d6338a189106a8cc9e3a1e0948 (diff)
gentoo auto-resync : 06:04:2024 - 00:30:33
Diffstat (limited to 'dev-python/parso')
-rw-r--r--dev-python/parso/Manifest2
-rw-r--r--dev-python/parso/parso-0.8.4.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/parso/Manifest b/dev-python/parso/Manifest
index 71ba96beb2ce..fb51770c79b3 100644
--- a/dev-python/parso/Manifest
+++ b/dev-python/parso/Manifest
@@ -1,3 +1,5 @@
DIST parso-0.8.3.gh.tar.gz 397648 BLAKE2B 8942408e27198075c92ef51f7a191cc7781eb3a5110119b91fd95f86e13ebe2fbfee11022a2bfec794150f60b3af8c4d5f324cb011703cd581c17f92232ae5bf SHA512 7874460053662d40c2cfcf0015e330e1c8201eeb07682e2079a636db553a82dc25b70b14ad0f0c82fb817f655359d695101a17f616abf9a39f49c61ae5fd49b1
+DIST parso-0.8.4.gh.tar.gz 398241 BLAKE2B 5a8a81f64b20b52cd3349b7bc059621733debfaf5cc271f3e89423d63e4af67391f7740c34b450b2a91fafe34b8986926e8f7c4ca0b8600eafd0171c01e664b0 SHA512 da96f0ab6cfbcf2a54ee73262a672bb4d9720aa91fd884a8c17165d597eece97569b7ee87fd7ea1c0be663c0cb2930a66a03b4e305070f59f346485817607db3
EBUILD parso-0.8.3-r1.ebuild 945 BLAKE2B 474cb2c7f0eb1cb74e4a760631084831b7a0a2126a6ee65211ec75a35d89aceb00de99c743f2aec15b2bc26ce3dc13dc2148cea1d960ab2bf458f6a8d6c9f35b SHA512 2a79541cc3aa8d75e102fc9738190363e8669b352c2d77fcddb678717e56c61c0f4c89eaa35df17a17d85cf2ed2fa078d2cfcb6d2ea2b0d01aee8ffe3137f1ab
+EBUILD parso-0.8.4.ebuild 953 BLAKE2B 77859d6883d79114a8ae7220f89ca64130806c3aa79b96420c6e8b21820a4096e9762985c4c420d73418448650874479a62a48c7155a870414f6f01f65b1c55d SHA512 7c2b8b9d258a99ef54ad533a545a4c3dfced45a31e2168845f20de783d709d19c776055f01d62211b3b6cb2e454f1ae593febb9ea66c57bc81dfeb6f51185ad8
MISC metadata.xml 403 BLAKE2B be2e4f9dd7e074a3b76a591f034f679bff13b7dc36d8b206e45550276533ba752a8e04162ddf4f580a8e247d57f48a997cac34c14dc7b5ae4a3d74751fb9cac4 SHA512 10517311994816074cfcc4809206ccbdb6a9ac3430e92cf9c4dfc45d8e95a92843843e2bf1a19b97aaa3c330bb923581e4ea6cf6a88f1063f2dab8d041f6c90f
diff --git a/dev-python/parso/parso-0.8.4.ebuild b/dev-python/parso/parso-0.8.4.ebuild
new file mode 100644
index 000000000000..8418e5c05160
--- /dev/null
+++ b/dev-python/parso/parso-0.8.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="
+ https://github.com/davidhalter/parso/
+ https://pypi.org/project/parso/
+"
+SRC_URI="
+ https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # py3.10 changed exception messages
+ test/test_python_errors.py::test_python_exception_matches
+ # With python3.11 this additional file is run by pytest,
+ # but it is not actually a test and thus fails
+ parso/python/token.py::parso.python.token.PythonTokenTypes
+)