summaryrefslogtreecommitdiff
path: root/dev-python/partd/partd-1.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-08 00:00:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-08 00:00:57 +0100
commit5181ced3f3566a9610b85922b083c8f84f20d78f (patch)
treed7eb288527e8bc248dd17ff874995d8bffe06704 /dev-python/partd/partd-1.4.2.ebuild
parent7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (diff)
gentoo auto-resync : 08:05:2024 - 00:00:57
Diffstat (limited to 'dev-python/partd/partd-1.4.2.ebuild')
-rw-r--r--dev-python/partd/partd-1.4.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/partd/partd-1.4.2.ebuild b/dev-python/partd/partd-1.4.2.ebuild
new file mode 100644
index 000000000000..8ee284590257
--- /dev/null
+++ b/dev-python/partd/partd-1.4.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Appendable key-value storage"
+HOMEPAGE="
+ https://github.com/dask/partd/
+ https://pypi.org/project/partd/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/locket[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/versioneer-0.20[${PYTHON_USEDEP}]
+ test? (
+ dev-python/blosc[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.3[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest