summaryrefslogtreecommitdiff
path: root/dev-python/paste/paste-3.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/paste/paste-3.0.7.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/paste/paste-3.0.7.ebuild')
-rw-r--r--dev-python/paste/paste-3.0.7.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/paste/paste-3.0.7.ebuild b/dev-python/paste/paste-3.0.7.ebuild
deleted file mode 100644
index 9153f2c37152..000000000000
--- a/dev-python/paste/paste-3.0.7.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="Paste"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
-HOMEPAGE="https://pypi.org/project/Paste/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris"
-IUSE="doc flup openid"
-
-RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/tempita-0.5.2_pre20130828[${PYTHON_USEDEP}]
- flup? ( dev-python/flup[$(python_gen_usedep 'python2*')] )
- openid? ( dev-python/python-openid[$(python_gen_usedep 'python2*')] )"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Disable failing tests.
- rm -f tests/test_cgiapp.py || die
- sed \
- -e "s/test_find_file/_&/" \
- -e "s/test_deep/_&/" \
- -e "s/test_static_parser/_&/" \
- -i tests/test_urlparser.py || die "sed failed"
-
- # Remove a test that runs against the paste website.
- rm -f tests/test_proxy.py || die
-
- local PATCHES=(
- "${FILESDIR}"/${PN}-2.0.3-unbundle-tempita.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile egg_info --egg-base "${BUILD_DIR}/lib"
-}
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- nosetests -P -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install egg_info --egg-base "${BUILD_DIR}/lib"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- distutils-r1_python_install_all
-
- find "${D}" -name '*.pth' -delete || die
-}