summaryrefslogtreecommitdiff
path: root/dev-python/pastedeploy/pastedeploy-2.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/pastedeploy/pastedeploy-2.0.1-r1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/pastedeploy/pastedeploy-2.0.1-r1.ebuild')
-rw-r--r--dev-python/pastedeploy/pastedeploy-2.0.1-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/pastedeploy/pastedeploy-2.0.1-r1.ebuild b/dev-python/pastedeploy/pastedeploy-2.0.1-r1.ebuild
deleted file mode 100644
index 69b46160987d..000000000000
--- a/dev-python/pastedeploy/pastedeploy-2.0.1-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-MY_PN="PasteDeploy"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Load, configure, and compose WSGI applications and servers"
-HOMEPAGE="https://pypi.org/project/PasteDeploy/"
-# pypi tarball does not include tests
-SRC_URI="https://github.com/Pylons/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="doc"
-
-RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -i 's:"pytest-runner"::' setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- use doc && dodoc docs/*.txt
- find "${D}" -name '*.pth' -delete || die
-}