summaryrefslogtreecommitdiff
path: root/dev-python/patch-ng/patch-ng-1.17.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /dev-python/patch-ng/patch-ng-1.17.4.ebuild
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'dev-python/patch-ng/patch-ng-1.17.4.ebuild')
-rw-r--r--dev-python/patch-ng/patch-ng-1.17.4.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/patch-ng/patch-ng-1.17.4.ebuild b/dev-python/patch-ng/patch-ng-1.17.4.ebuild
index ccbdec8387b8..ba2038b565a1 100644
--- a/dev-python/patch-ng/patch-ng-1.17.4.ebuild
+++ b/dev-python/patch-ng/patch-ng-1.17.4.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Library to parse and apply unified diffs, fork of dev-python/patch"
HOMEPAGE="https://github.com/conan-io/python-patch-ng https://pypi.org/project/patch-ng/"
SRC_URI="https://github.com/conan-io/python-patch-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-${P}"
LICENSE="MIT"
SLOT="0"
@@ -16,8 +17,6 @@ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
distutils_enable_tests unittest
-S="${WORKDIR}/python-${P}"
-
python_test() {
- "${EPYTHON}" -m unittest tests/run_tests.py || die "Tests failed under ${EPYTHON}"
+ "${EPYTHON}" -m unittest -v tests/run_tests.py || die "Tests failed under ${EPYTHON}"
}