summaryrefslogtreecommitdiff
path: root/dev-python/path
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-07 10:16:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-07 10:16:30 +0100
commit2c9fab2a3468abc6862cb3115c9ff63aa266bf57 (patch)
treeb9249df06dd8229d7f334cb2e536d5c56ac81d3c /dev-python/path
parent0735b7c70f35339a20b45aee2a0a0ad80d118550 (diff)
gentoo auto-resync : 07:07:2023 - 10:16:30
Diffstat (limited to 'dev-python/path')
-rw-r--r--dev-python/path/Manifest2
-rw-r--r--dev-python/path/path-16.7.1.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
index 7114f8552b94..c84fcbfa90ab 100644
--- a/dev-python/path/Manifest
+++ b/dev-python/path/Manifest
@@ -1,3 +1,5 @@
DIST path-16.6.0.tar.gz 49670 BLAKE2B 16da36676acb4e4c45c364a09c1d031f4cfc6bdabc08426bc5a8945c4b3594a7dd849f880f76dbfaba4dd2282eee00edbc0f9c7c4ed4774750e023c6a03b3939 SHA512 f1ec159c6b755f98eef90e1aac4337fb84fd9f739beddf34205c5faf9e959863baa52d237899bd33fe8f365a2666af6999c2e9388be310a6acae16b4952df022
+DIST path-16.7.1.tar.gz 48974 BLAKE2B a03eebbb391cf17033adce4d6b258217546e3b7494200a8ea97f756512177f1c7d7ea8155420e167cefe79b566a4240eec98d17b160478f9cb06d3fd839c28f2 SHA512 7d660373046845a5882a316051c350558527d6d8a5cd11735d38214f986c8e096f72b45f87cfec41bf6171e7845287a42e6e45535f87a01b46670eccd4013dbf
EBUILD path-16.6.0-r1.ebuild 786 BLAKE2B 075abfad316a7be240051922918553af04018b047503b2ace22ae5b0772d4aa6c8eb34fa5fed818cc3965ca003980dae00a00b8021eb593b161253d8d0314480 SHA512 967193e6ea64daca18f45b35d84e1e80d4e796d52bc980fbafd2d7607c4e479416967f386b017a69cd61ceebe4288b0a364195df181501de6f152a5f81cc2f9e
+EBUILD path-16.7.1.ebuild 795 BLAKE2B e3954e2109c84c2191ceece7696f2b0f48cfe68d370d3f3cf964e049e1c01fc473612719db44b97f22380327ecfa2f1f45aa123137f76462ab998ee4b2fdeeaf SHA512 c0dded841cd3cd83dda1f832da6d879060da3da7e045a72d3104198c75c72cdf900ce6d03a72d9bda9094e3d6077e5468cc8dc1207e3ba2ba8a62d29374587be
MISC metadata.xml 383 BLAKE2B 30f12776bf4f9c1995774d7dc68cd8d9a85b74d514e8239ba76af336e6b08979e496ddaffce999bf0a3557f88ced148335024628b61f765b5bd08bf90b453c5a SHA512 aaceff1caa2714c0b8b3f7373c8721358e63833cfac824e3feda8a34fd1d6a961a27805c012a1125cad1f76d8bf7b1a92d7719480d90b344e5b4d0260ccf0547
diff --git a/dev-python/path/path-16.7.1.ebuild b/dev-python/path/path-16.7.1.ebuild
new file mode 100644
index 000000000000..6cd8ba8201ed
--- /dev/null
+++ b/dev-python/path/path-16.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)