summaryrefslogtreecommitdiff
path: root/dev-python/patsy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-python/patsy
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-python/patsy')
-rw-r--r--dev-python/patsy/Manifest2
-rw-r--r--dev-python/patsy/patsy-0.5.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/patsy/Manifest b/dev-python/patsy/Manifest
index 0fc2633276cd..3bf8c7977aef 100644
--- a/dev-python/patsy/Manifest
+++ b/dev-python/patsy/Manifest
@@ -1,3 +1,5 @@
DIST patsy-0.4.1.zip 425390 BLAKE2B b8d5696abcf35fcd5e49a7d3efdfb201976efdbe7e845f136dd0cdbfb0972d8372e54b8f4141139cff9ad4df3525c67a10a3c71bc1471991a810e834e0dd0ad9 SHA512 24cf2e6f9a33e6dd795a839eb2b2ac9e0d45cd9c3d5250de17722914ac29436d0518388d0696b75d73236eda3c7819dc4fa24d6d9bc37d5ae035dde2af4510c3
+DIST patsy-0.5.1.tar.gz 397623 BLAKE2B b8861e8c8e223db5df616c378d5b1ce475a1b337d049723c1a4b01432d9e1569c4b6537dc467fbc1ba83dfc7cd999ad188008e387c446f2133f872393c9eb960 SHA512 aeb56411e68713ec75c0b5344890939f721c460d3c7643b9fd57d7c928421d21408b0f2963348edf27a025842989dbae6fd5cfccd3f9d9497d60a1dffe8d7bdc
EBUILD patsy-0.4.1.ebuild 1108 BLAKE2B 75d820414680e71455c9b71c669586d2b7ffcd09d1dabc72b170fd1fc626388b4c9afa63d8c31c146fc3b4e3bdd5535d0afc42a99baf48fb89156088a19fca47 SHA512 6a5424428cd8cc91cb955ebfd5e3c0c2dc27fee6ac76e6de2d98ffb6ac5877d0ceceff287f3a9737e815fdd11771faa155f3b36cd3ec7916a3f74236d52f56ba
+EBUILD patsy-0.5.1.ebuild 1192 BLAKE2B 51b7809939699c66bc797ec726809fecd3b40d8abc7a1a8281375b768a98c4700babb867b6fd052b9e352fdfc15487ee0b86bed6066697395b3faf575bafbb54 SHA512 72aa988c3efebd706a5c73d3c315234dbd402c4cbe4055c8d5af3e93c2a35e74a634a36a3b0dcf53361747285f8c31746de61f2d764eca97c468beee77f47613
MISC metadata.xml 568 BLAKE2B 198b70af00599da8c516753e5ec88fb4353a966a279e4e40db5b57a7bab57f0ec360ac70ebe4dc14b194b147520b0a8d6d35d2e73003c9c70bbbcc3c830b91aa SHA512 57957dc18e93d9bc8d53d72bf8c9e601856ffb1511943034ff30aa7d93761f8b986e67daadf8dbcd57ef7714ebf3dda13ccd345df294809954c942cb9bdd1310
diff --git a/dev-python/patsy/patsy-0.5.1.ebuild b/dev-python/patsy/patsy-0.5.1.ebuild
new file mode 100644
index 000000000000..dc375b85bbf6
--- /dev/null
+++ b/dev-python/patsy/patsy-0.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="http://patsy.readthedocs.org/en/latest/index.html"
+SRC_URI="https://files.pythonhosted.org/packages/49/c7/b971d8685c52512dbaa45bf8d076695432245a9f59509fb20a6c8e4ff69a/patsy-0.5.1.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}