summaryrefslogtreecommitdiff
path: root/dev-python/pbr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-11 23:45:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-11 23:45:17 +0000
commit7051f2e58b6bbc371b2c94cead2715bf06310adb (patch)
treed8eb7cbcdfa3883fcdb1cb004774e17be52600b0 /dev-python/pbr
parent3b4acc0bc0b77136b371d8a3119066f80f221efe (diff)
gentoo auto-resync : 11:01:2023 - 23:45:17
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest2
-rw-r--r--dev-python/pbr/pbr-5.11.1.ebuild73
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index e20383fcae4c..25564626c862 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1,3 +1,5 @@
DIST pbr-5.11.0.tar.gz 127505 BLAKE2B 201fcd04ded1f909f4792886ddf79a5a764318645ff6b6245543cde2940d502ab711820cb6e999894a339df933e43e6a8394bd8ec1e978d930710a3085b131fd SHA512 bdb442e8ef7bda90a65c5fb7f0696041808278fcc643eb0c15d5401b7da7d64cd3566018b1046145f55bc5683791ee182bec92461801004b02a35b8bf4c5abf0
+DIST pbr-5.11.1.tar.gz 127597 BLAKE2B 4ed433f271b4cbed3e7baca66cbeef057d575b7b061507c45a65ba93704edbed7b6f8668e9b9766f03079aaf06dbd6c394960c1c528b1beb992db65d0c3b89e4 SHA512 466dc5ce2622c43451186698f00d405141878449ffe9f7771b0057e8356bf12b426a9bfefff7e5843f1b3f963af3ffc9c4a42fa91a9407b79617abea046ff438
EBUILD pbr-5.11.0.ebuild 2186 BLAKE2B 6443d6610caaef9dc65144a5544db1d25e79aed8af8f279f6e45405a7a74bf5caf45167067d84dd1ac817d161e14601f11ff065935fe58a139a40b02d3c44241 SHA512 d953d8d72fadc4636170387307c1019fa52667ea9704a76d41a4d8aa8146ee47e8b0993a0e024d967a4c963f25b69fb5cf4798d66e0d3d2e695ce82846cab4bc
+EBUILD pbr-5.11.1.ebuild 2194 BLAKE2B 2359e1bace035bc2402fa6e7ce65532aec88dbee59aa224a7b668b7d931e6b49b0b001c7f6f54499bbf3afee0dd7d89fe5756044f7cf84c629865806465ed80c SHA512 b69d9872f3de54fd29b6da4f7a6b9c940e7e73a7e23c2ad3f5088093ec198bae36f967a268529c3905a189bcaa39f77bae61d5c3bc5a3fb06f1778191192cc26
MISC metadata.xml 815 BLAKE2B 439ee90d79572a8653f1ae3b8b5bf0883adb34ceac5257458dba7a2505e25ebba1c5080095139f6521d8fbd57c11ea38cf4049710b584069aea0ebaa7760077a SHA512 3d0618ef6656706acd829be80b2e6a0b0763b5f4128dcd360f28818d42cbc8825ecd04f7f47af5929a3a35fd60a3b9f9816cc37ee30af164c2e5b51764c25afe
diff --git a/dev-python/pbr/pbr-5.11.1.ebuild b/dev-python/pbr/pbr-5.11.1.ebuild
new file mode 100644
index 000000000000..48675f59e932
--- /dev/null
+++ b/dev-python/pbr/pbr-5.11.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_TESTED=( python3_{8..11} )
+PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="
+ https://opendev.org/openstack/pbr/
+ https://github.com/openstack/pbr/
+ https://pypi.org/project/pbr/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/setuptools-60.5.0[${PYTHON_USEDEP}]
+"
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
+# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+# stestr is run as external tool
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
+ dev-vcs/git
+ ' "${PYTHON_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # TODO: investigate
+ sed -e 's:test_console_script_develop:_&:' \
+ -e 's:test_console_script_install:_&:' \
+ -e 's:test_setup_py_keywords:_&:' \
+ -i pbr/tests/test_core.py || die
+ # network
+ rm pbr/tests/test_wsgi.py || die
+ # installs random packages via pip from the Internet
+ sed -e 's:test_requirement_parsing:_&:' \
+ -e 's:test_pep_517_support:_&:' \
+ -i pbr/tests/test_packaging.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if ! has "${EPYTHON}" "${PYTHON_TESTED[@]/_/.}"; then
+ einfo "Testing on ${EPYTHON} is not supported at the moment"
+ return
+ fi
+
+ eunittest -b
+}