summaryrefslogtreecommitdiff
path: root/dev-python/pbs-installer/pbs-installer-2025.02.05.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-08 00:11:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-08 00:11:30 +0000
commit8b3c41ecef8a1cdd270ce3aabcfdfb991839699c (patch)
treeece43c29d9163f887ef99c43aad6f2f568961231 /dev-python/pbs-installer/pbs-installer-2025.02.05.ebuild
parent1b2360e7bab42e4045232887cb4f6c4a24ca3975 (diff)
gentoo auto-resync : 08:02:2025 - 00:11:30HEADmaster
Diffstat (limited to 'dev-python/pbs-installer/pbs-installer-2025.02.05.ebuild')
-rw-r--r--dev-python/pbs-installer/pbs-installer-2025.02.05.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pbs-installer/pbs-installer-2025.02.05.ebuild b/dev-python/pbs-installer/pbs-installer-2025.02.05.ebuild
new file mode 100644
index 000000000000..9eda0a2dfbf3
--- /dev/null
+++ b/dev-python/pbs-installer/pbs-installer-2025.02.05.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Installer for Python Build Standalone"
+HOMEPAGE="
+ https://pypi.org/project/pbs-installer/
+ https://github.com/frostming/pbs-installer/
+
+"
+SRC_URI="
+ https://github.com/frostming/pbs-installer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND="
+ dev-python/zstandard[${PYTHON_USEDEP}]
+"
+
+# upstream does not provide any tests
+RESTRICT=test
+
+python_configure_all() {
+ export PDM_BUILD_SCM_VERSION=${PV}
+}