summaryrefslogtreecommitdiff
path: root/dev-python/pbs-installer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-18 04:04:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-18 04:04:23 +0100
commit483d7c056fba15727fe24545f93627a1d1e1e2eb (patch)
tree80d144b60f8e1dc0d14c15cb3e5950da12c80074 /dev-python/pbs-installer
parent8796aaedb3257bbe4d80b0033408b2210b2259d6 (diff)
gentoo auto-resync : 18:10:2024 - 04:04:23
Diffstat (limited to 'dev-python/pbs-installer')
-rw-r--r--dev-python/pbs-installer/Manifest2
-rw-r--r--dev-python/pbs-installer/pbs-installer-2024.10.16.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pbs-installer/Manifest b/dev-python/pbs-installer/Manifest
index a507b2b06be9..efbad3002856 100644
--- a/dev-python/pbs-installer/Manifest
+++ b/dev-python/pbs-installer/Manifest
@@ -1,3 +1,5 @@
+DIST pbs-installer-2024.10.16.gh.tar.gz 79499 BLAKE2B 749a0ecc54a4df1e5989eee54b874b92bd7592307fe9bc0a13aa77dea96dcec8b6ff7b5fcfd10e354eaad21054cbf264c718fa7d692c6ee2df348f9217ca89ca SHA512 1b6bfc64bf311d03cf318365b1d16968ac599b40b247970477d6555791407bc104813bd60f82e30d88a13cd37873fef269a98640ee301f86028e6ddf7d097958
DIST pbs-installer-2024.4.24.gh.tar.gz 73601 BLAKE2B f56483899dc7795d0334b4698e08f71799ede456fdb7f78accc9278f32437a6b785055ec0b61854c6ec05663bc3b4bd41be8d45138a5793dcab35aa80da32de8 SHA512 7bd440e1522a1c826dcfac801763ad256d79f60315a30828082ea65169e5f4cc8527866491a5c4d84d847150ed6f90167b550104031f417e0103640e2c291aeb
+EBUILD pbs-installer-2024.10.16.ebuild 667 BLAKE2B 1ebd0d0a74db54be51c9b00478398b348644b4c2a3d9b7ebad1c188abf7d53051d7b5bf6a284b223aca8454c2e6c6ca6610aa6ada6954f7f6b54f97c85b655df SHA512 6a429ba6ad1c60a2e46a5ddfb2d5f88f9aa8a8b8b96e9a71db46fc9b188bf7e25f42f6f167ea69cb50dc05ecfb43edb6a0644a562e8634933b084f0949bc3227
EBUILD pbs-installer-2024.4.24.ebuild 667 BLAKE2B 1ebd0d0a74db54be51c9b00478398b348644b4c2a3d9b7ebad1c188abf7d53051d7b5bf6a284b223aca8454c2e6c6ca6610aa6ada6954f7f6b54f97c85b655df SHA512 6a429ba6ad1c60a2e46a5ddfb2d5f88f9aa8a8b8b96e9a71db46fc9b188bf7e25f42f6f167ea69cb50dc05ecfb43edb6a0644a562e8634933b084f0949bc3227
MISC metadata.xml 389 BLAKE2B a37933cd9532954bab2a95cd74e8418c74b1fcf22e1916c39307c7f55e90ec8a086ab923a02111708e81b1a4103c1460a946f11d2f20eb837cc3dbe3386f45b9 SHA512 15f19301b81afb97098afd2174c89f0dd5f0cbe7fc1f7a31d13fc68c11d70d2f9190e1417d3d980503f278c7c3bbc6fc322bd0aeaa3de3da72e6e58190aaf107
diff --git a/dev-python/pbs-installer/pbs-installer-2024.10.16.ebuild b/dev-python/pbs-installer/pbs-installer-2024.10.16.ebuild
new file mode 100644
index 000000000000..c2bbf1f95bc4
--- /dev/null
+++ b/dev-python/pbs-installer/pbs-installer-2024.10.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Installer for Python Build Standalone"
+HOMEPAGE="
+ https://pypi.org/project/pbs-installer/
+ https://github.com/frostming/pbs-installer/
+
+"
+SRC_URI="
+ https://github.com/frostming/pbs-installer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND="
+ dev-python/zstandard[${PYTHON_USEDEP}]
+"
+
+# upstream does not provide any tests
+RESTRICT=test
+
+python_configure_all() {
+ export PDM_BUILD_SCM_VERSION=${PV}
+}