summaryrefslogtreecommitdiff
path: root/dev-python/pdm/pdm-2.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
commit12795ed0561fe52503d6aa3a1c60888553a03bd2 (patch)
treebebc6554f117bd11f5e1c3503ed66966afcb5f3f /dev-python/pdm/pdm-2.10.0.ebuild
parent7e8f2c69a019131eaeb989242d022260ea5a84ff (diff)
gentoo auto-resync : 26:10:2023 - 20:41:49
Diffstat (limited to 'dev-python/pdm/pdm-2.10.0.ebuild')
-rw-r--r--dev-python/pdm/pdm-2.10.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/pdm/pdm-2.10.0.ebuild b/dev-python/pdm/pdm-2.10.0.ebuild
index 67faee70f040..829b67f4dbf6 100644
--- a/dev-python/pdm/pdm-2.10.0.ebuild
+++ b/dev-python/pdm/pdm-2.10.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=pdm-backend
PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1 pypi
+inherit distutils-r1 multiprocessing pypi
DESCRIPTION="Python package and dependency manager supporting the latest PEP standards"
HOMEPAGE="
@@ -45,6 +45,7 @@ BDEPEND="
test? (
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"
@@ -72,5 +73,8 @@ python_test() {
tests/test_project.py::test_project_packages_path
)
- epytest -m "not network and not integration and not path"
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network and not integration and not path" \
+ -p pytest_mock \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
}