summaryrefslogtreecommitdiff
path: root/dev-python/pefile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-29 12:00:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-29 12:00:47 +0100
commitadcf4f8116a4a850dae301fb4dbcd7b71cb35975 (patch)
tree41af0dd08b04c7d619cdfed205b03ff2cc201b26 /dev-python/pefile
parent7166f3a0a0b7886d340010458d0b130013cb9989 (diff)
gentoo auto-resync : 29:08:2024 - 12:00:47
Diffstat (limited to 'dev-python/pefile')
-rw-r--r--dev-python/pefile/Manifest4
-rw-r--r--dev-python/pefile/pefile-2024.8.26.ebuild27
-rw-r--r--dev-python/pefile/pefile-9999.ebuild3
3 files changed, 32 insertions, 2 deletions
diff --git a/dev-python/pefile/Manifest b/dev-python/pefile/Manifest
index f10f2a41680a..d575fda0f2ec 100644
--- a/dev-python/pefile/Manifest
+++ b/dev-python/pefile/Manifest
@@ -1,4 +1,6 @@
DIST pefile-2023.2.7.gh.tar.gz 74852 BLAKE2B ddca4b8ef37af829bb1757eb4c4ba9f46c3914e05e6c13e13a8e5a3c88a608aba486deec9338400fddae4591867c0c7dcf7325cee14d42b1bb724751a3a2a7f0 SHA512 241d9846954f094ed39e61d80e7d8c1612829ec909650175e75657f9cf69c9bef9e2a115d4106bb14757125c0ffaa3e93abfb2f078e80326e78ac5818c7c2fd3
+DIST pefile-2024.8.26.gh.tar.gz 76008 BLAKE2B 7f21d07bbe9a08239739f589e35d0ef4b5172e26b2a90acdbedc7792be70fdb0d4ee01888d674384fb011f3c716406c1b1a23b29fa412ce01863cae89acbc4bc SHA512 62781f2ab84040a13304ce550dd1e943991df152c5f2951281906e837b1659694051a074ff49cd08d5d508e9b70009b56418a4237511c4464c4eba9bda4bccf7
EBUILD pefile-2023.2.7.ebuild 844 BLAKE2B 9ba5617c634419530420a848bb5fc50c762cef598184b7ea3f4ff0160ffc83b6e9a0dcf8f02f107c6c03e9aecd9ab3ee9bd5fd837f73a4a21ec8ae2abc1085bd SHA512 a325adbf2cd9024a500929dbff27d58711a8ce9a2719f24308bdce881a5cf4ad6e77d5d31240ed8203fb08c7eb65c6f5e47ab150e1832ef53b7065226122776a
-EBUILD pefile-9999.ebuild 836 BLAKE2B cb29f20dbaedf2147ed5f8d630ed6e097839419b57c763a04adf15a8737e2788afd9f2aaa87bc7eae678b5aa3dc8c9dfafd730778d4c9816fc684fde9ad76186 SHA512 be1d6aa105954cf2caeda4bea19996abc75cd55353aa7c0095c59e59df5ef19a152af4f6e013e88c42a2120f185f349e1449918ae31eb7b05a894a8e591b3710
+EBUILD pefile-2024.8.26.ebuild 866 BLAKE2B 9767046d852e889e16ebd7fe64be1546e9e8c84f5ba18eb2c90060993fb43b715f5b2e35579a02b167e3fc22774f2b23d9333b1176a0e4e564ef435e51c3cd06 SHA512 9c2d88eb66a2ce06feb4dc8fb8c4bb26d55cc4d793613bfc3e6919dc62e3a5803b1d72d490ab3df1e73a727f72fe9be73573d4c595daba3e60e5d546d700dda3
+EBUILD pefile-9999.ebuild 866 BLAKE2B 9767046d852e889e16ebd7fe64be1546e9e8c84f5ba18eb2c90060993fb43b715f5b2e35579a02b167e3fc22774f2b23d9333b1176a0e4e564ef435e51c3cd06 SHA512 9c2d88eb66a2ce06feb4dc8fb8c4bb26d55cc4d793613bfc3e6919dc62e3a5803b1d72d490ab3df1e73a727f72fe9be73573d4c595daba3e60e5d546d700dda3
MISC metadata.xml 766 BLAKE2B 8cd0206bb0cc7de9a76159851092c27b5e7c6d8294a136de2dd74e51da9062f6daa67c2421c173b6125758a9f350b84b03e2a85fa2029beb50032aa034f08c3a SHA512 7c3e9d6d89108b17a722c805353a9c457ccb5a5233bfca7145f82a37ab0337405c84a1e806d9fba77dbee779dd06cb18f7272399277d377aa84dcafc470156bf
diff --git a/dev-python/pefile/pefile-2024.8.26.ebuild b/dev-python/pefile/pefile-2024.8.26.ebuild
new file mode 100644
index 000000000000..3eecccc699f3
--- /dev/null
+++ b/dev-python/pefile/pefile-2024.8.26.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Module to read and work with Portable Executable (PE) files"
+HOMEPAGE="https://github.com/erocarrera/pefile"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/erocarrera/pefile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/erocarrera/pefile/releases/download/v${PV}/${P}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+# Unfortunately there is nothing we can test here. Upstream doesn't ship a test
+# suite inside the release files. The test fixtures in the source repo is
+# encrypted so that only their CI pipeline is able to run the tests.
+RESTRICT="test"
diff --git a/dev-python/pefile/pefile-9999.ebuild b/dev-python/pefile/pefile-9999.ebuild
index 0c98bc8157ef..3eecccc699f3 100644
--- a/dev-python/pefile/pefile-9999.ebuild
+++ b/dev-python/pefile/pefile-9999.ebuild
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/erocarrera/pefile/releases/download/v${PV}/${P}.tar.gz -> ${P}.gh.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
fi
LICENSE="MIT"
@@ -24,3 +24,4 @@ SLOT="0"
# Unfortunately there is nothing we can test here. Upstream doesn't ship a test
# suite inside the release files. The test fixtures in the source repo is
# encrypted so that only their CI pipeline is able to run the tests.
+RESTRICT="test"