summaryrefslogtreecommitdiff
path: root/dev-python/pendulum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/pendulum
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/pendulum')
-rw-r--r--dev-python/pendulum/Manifest3
-rw-r--r--dev-python/pendulum/metadata.xml16
-rw-r--r--dev-python/pendulum/pendulum-2.1.2-r1.ebuild36
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pendulum/Manifest b/dev-python/pendulum/Manifest
new file mode 100644
index 000000000000..10bc9c6ea997
--- /dev/null
+++ b/dev-python/pendulum/Manifest
@@ -0,0 +1,3 @@
+DIST pendulum-2.1.2.tar.gz 159885 BLAKE2B c95cd131fc95a0d19ef11f180cc42126cb8a6ea3aaf4b3bbedbc5ce4c1b37a6624f2a1be92f1a6fd6b1f14f5d20fa5f32e8230f896ab7a216f02f00e85b98738 SHA512 c367320ade0d10b7eb9c880286176161b925d7df052f7de85ddd169594bbe778776ea74df451f00186df98be3e32b7399c68ca4b40123e2c456206410e3a1ab2
+EBUILD pendulum-2.1.2-r1.ebuild 1015 BLAKE2B e7fa249c719a4021cf38b711da36b2f126c02739e92188715f7bdb317fc8dec341be6b31494c8c24fff60241101149774cff8b99a7ea84549554cd81d91ae78c SHA512 3b62cd6944857c0fde598c226b57a68ed5c74548c72bbaf4bab2cb9f262deb5c3f5a8af36f7369f960e3b5bca4bcc176afb97b138cf13b5cf4a84cd91e68698e
+MISC metadata.xml 515 BLAKE2B 836e056a0ea2aa33fd1d3fb9bb6fda8539ebb1395038e3b264302e8b6b63397840f3413bccd4bd1fe24ecceec8075ed3313f8404cab60a386c1c9eed902bc6d2 SHA512 e61f93ccb5176ea9693f9d03bd6b583db8154b9673e63ab683841b4ab9f611ffc2072bcb9c19c199f93b7fdec1cdc87c82fdfb688733de449f1a59a7a25f70f4
diff --git a/dev-python/pendulum/metadata.xml b/dev-python/pendulum/metadata.xml
new file mode 100644
index 000000000000..2f00533e580f
--- /dev/null
+++ b/dev-python/pendulum/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jakov.smolic@sartura.hr</email>
+ <name>Jakov Smolic</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sdispater/pendulum</remote-id>
+ <remote-id type="pypi">pendulum</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pendulum/pendulum-2.1.2-r1.ebuild b/dev-python/pendulum/pendulum-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..c17277cd71fc
--- /dev/null
+++ b/dev-python/pendulum/pendulum-2.1.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for the standard datetime class"
+HOMEPAGE="https://pendulum.eustace.io/ https://github.com/sdispater/pendulum"
+SRC_URI="https://github.com/sdispater/pendulum/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Requires timezone information which is not installed by default
+# with dev-python/pytzdata, and otherwise approx. 50 out of 1600
+# tests are failing for now. Keeping the test dependencies
+# commented for future tests fixups
+RESTRICT="test"
+
+DEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytzdata[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+#BDEPEND="
+# test? (
+# dev-python/babel[${PYTHON_USEDEP}]
+# dev-python/freezegun[${PYTHON_USEDEP}]
+# dev-python/pytz[${PYTHON_USEDEP}]
+# )"
+
+# distutils_enable_tests pytest