summaryrefslogtreecommitdiff
path: root/dev-python/pep8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/pep8
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/pep8')
-rw-r--r--dev-python/pep8/Manifest2
-rw-r--r--dev-python/pep8/pep8-1.7.1.ebuild27
2 files changed, 10 insertions, 19 deletions
diff --git a/dev-python/pep8/Manifest b/dev-python/pep8/Manifest
index edf5d3ca048e..d4e73f2c4141 100644
--- a/dev-python/pep8/Manifest
+++ b/dev-python/pep8/Manifest
@@ -1,3 +1,3 @@
DIST pep8-1.7.1.tar.gz 80334 BLAKE2B 71a038c8fbcbd7c94ff713d1eb8fa248106d283fb520f97fe35819b14382eff6e55683b739acd933cfe22001ed262f76a9b6f3f55661938b3b199ec1f4c35745 SHA512 d20d6a6f91bc865580e3d39c50e26f9c6be81fd8e80a1b9a029d7ea9c906748e46080b841dc5507004089e5ee0d0cb3f70a74bb35131c58113ff5571153af4da
-EBUILD pep8-1.7.1.ebuild 1072 BLAKE2B 58ed1820653b2065e71cbcf0cb2b93471d31ff19eda3135450e9eb4e7773e7e86fe1c475e4d7658bf42d42ba12350cda0c2d68ed717c798410a91d16bbaa6e41 SHA512 10ea17efdb7bdc0082fc9a906d8d9918141322ef981149576ba484cfe693528ff6eb2d0cf4cda5e16f9e31c2ede8b6e18d0ee5d30594ae6c829608d895bd1c5c
+EBUILD pep8-1.7.1.ebuild 857 BLAKE2B 92d49caea55f426384f0ed3ee81cfe5629826e6e82ee2b2e2851fd827b6369ccd9fe0761f7c19e704798367f03ef45cd7bfe111cfaa1bdf3e321368295b25976 SHA512 620d9fa6d68448cde82f658d70454b710e56ada6dcb46e2d2b93b34946162eb0cccf8c28b3c1893a7bc58f30b5f49b14c59eec967d046ef21328cc3597b2e368
MISC metadata.xml 398 BLAKE2B 36900845777c438858178ad562d5da58efd9e2e39b6ce3a062cb6bdfb48f970dbe6d18e57dce711b4dbf1efa6c65fd4b52329b4a2a293bfc21661670a7c1daf5 SHA512 e700e6ff7cf5fb6e85874a2ef1c07d35b635ae55ba0d9e346b4fa9fe2928691203571a85d2a9f63ddbdb3d51904b4503ec046adf4e732c18e825b005dd7c2125
diff --git a/dev-python/pep8/pep8-1.7.1.ebuild b/dev-python/pep8/pep8-1.7.1.ebuild
index f149f5a45665..b8c60182e655 100644
--- a/dev-python/pep8/pep8-1.7.1.ebuild
+++ b/dev-python/pep8/pep8-1.7.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
inherit distutils-r1
@@ -15,23 +15,14 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- PYTHONPATH="${S}" "${PYTHON}" pep8.py -v --statistics pep8.py || die
- PYTHONPATH="${S}" "${PYTHON}" pep8.py -v --testsuite=testsuite || die
- PYTHONPATH="${S}" "${PYTHON}" pep8.py --doctest -v || die
- esetup.py test
-}
+python_prepare_all() {
+ # AssertionError: 7 is not false : 7 failure(s)
+ sed -i -e 's:test_checkers_testsuite:_&:' \
+ testsuite/test_all.py || die
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
+ distutils-r1_python_prepare_all
}