summaryrefslogtreecommitdiff
path: root/dev-python/pexpect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pexpect
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/Manifest3
-rw-r--r--dev-python/pexpect/metadata.xml12
-rw-r--r--dev-python/pexpect/pexpect-4.2.1.ebuild40
3 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/pexpect/Manifest b/dev-python/pexpect/Manifest
deleted file mode 100644
index ea9510d88ca5..000000000000
--- a/dev-python/pexpect/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pexpect-4.2.1.tar.gz 143980 BLAKE2B b5cb9c7847eabdf8778bddc6b208520edb9b3611d7a981fae6e371fa6deafebe142ba8361e3a1d21187cd692576c91d732f3def75e19989296f50b2a9fb4d4c6 SHA512 796474c87559cb9f4e2dfe72564d70c75e1aac4f57c4f3e4033a56c8842a48380ae0d5fafdad7f1ea6718b25c272fe4a611a59db44e69afb1f2bbf7e00256261
-EBUILD pexpect-4.2.1.ebuild 1162 BLAKE2B 441552088625ea18bbb4944ff66d40e2f29afc05a57d042fbc2526735ee94459522772f3c7b9b6916db56034df71a8f35570396b6d31b515c3ac5ac55a5e339f SHA512 ca44c829566aabf1b45e7a7996733bbb67d6ad71e8b1ffccb3ac040cdb26fda5c5394c2af8c7bd9d5ce17812e9d4457000c8de1846b649667160578605571883
-MISC metadata.xml 377 BLAKE2B 72c4b35c12a770df9344987af8c7a392c3aed05296a4876902987ef946239f8318ee833cc81a7f004719e954670a83e84a3813bcdaac48912efad885515de1ea SHA512 31e65b2ce9ec12e9d3e95ed651841b8aad6a24330fe20b4bfd6351267423ff5005ac3cb2e89dbb8f024cf60705d3f06a8a1309169a029eb5246ddc45a8d76464
diff --git a/dev-python/pexpect/metadata.xml b/dev-python/pexpect/metadata.xml
deleted file mode 100644
index 311134caccb6..000000000000
--- a/dev-python/pexpect/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">pexpect</remote-id>
- <remote-id type="github">pexpect/pexpect</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pexpect/pexpect-4.2.1.ebuild b/dev-python/pexpect/pexpect-4.2.1.ebuild
deleted file mode 100644
index 4ec6aea19456..000000000000
--- a/dev-python/pexpect/pexpect-4.2.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
-HOMEPAGE="https://pexpect.readthedocs.io/ https://pypi.org/project/pexpect/ https://github.com/pexpect/pexpect/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-RDEPEND=">=dev-python/ptyprocess-0.5[${PYTHON_USEDEP}]"
-DEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- py.test tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}