summaryrefslogtreecommitdiff
path: root/dev-python/pexpect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
commita8b0d35ab742f31538d515dea39716e566d533c0 (patch)
tree40c6c87a13f0e5ef1111ed1bdd9191f3bd1c1e59 /dev-python/pexpect
parent8fcdcec5fbdd0e3a77391e4f354218014f59f358 (diff)
gentoo resync : 06.01.2018
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/Manifest2
-rw-r--r--dev-python/pexpect/pexpect-3.3.ebuild36
2 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/pexpect/Manifest b/dev-python/pexpect/Manifest
index 35f418a95e9f..db069822fe95 100644
--- a/dev-python/pexpect/Manifest
+++ b/dev-python/pexpect/Manifest
@@ -1,5 +1,3 @@
-DIST pexpect-3.3.tar.gz 132330 BLAKE2B 3dcbc10aa6029fdcc7930bca355583c146661d21820f2fafa2886bfe130c2c0d632bf9edfa5f96f5eae68b5dc7202e1d4bdcc3ea8593ee98346cdd7c354b6ac9 SHA512 66cc501f1c7bb8ba0be4cdc0db840629f51416dc54ae44dc770adb38f1a385116b0a8b9bc7f1cc1447f05ede36ef1b519f5c4e710e6cb736c923ecfc87497cfa
DIST pexpect-4.2.1.tar.gz 143980 BLAKE2B b5cb9c7847eabdf8778bddc6b208520edb9b3611d7a981fae6e371fa6deafebe142ba8361e3a1d21187cd692576c91d732f3def75e19989296f50b2a9fb4d4c6 SHA512 796474c87559cb9f4e2dfe72564d70c75e1aac4f57c4f3e4033a56c8842a48380ae0d5fafdad7f1ea6718b25c272fe4a611a59db44e69afb1f2bbf7e00256261
-EBUILD pexpect-3.3.ebuild 1068 BLAKE2B 966e9db3bc3297e67a97f5520863bf7bc782fd232d33f7b8ff2194d80bc1eecf14ce4b15bd47fd93ebb77bb545de67da222062a6e9826ce4a90c7ee811aad923 SHA512 0273ebbbba5c3ce1f60956fd7c8b99f374d148e40e6fdc6910e0febc71bd6bc64e83f28f01520ed54a0dc1b400e8b9f6131d63020a2d79974f04b673a13bb5b6
EBUILD pexpect-4.2.1.ebuild 1167 BLAKE2B 4940428c2fcfa46a9414ebded2974e237ab444c6ae3670608c09adce5df667cfa4bb006756e93bb3e538a2465e17e82f3c4c500c27cd1b499677e12369cda085 SHA512 5e054ad606ec614c25ee0148a25af89fc5c5effbd9a0f5119e27ac5b808fd246831c337a90f7b5b427b3538cde8c6b0778dd6ff54e9edf9afe3216c61cd018d5
MISC metadata.xml 377 BLAKE2B 72c4b35c12a770df9344987af8c7a392c3aed05296a4876902987ef946239f8318ee833cc81a7f004719e954670a83e84a3813bcdaac48912efad885515de1ea SHA512 31e65b2ce9ec12e9d3e95ed651841b8aad6a24330fe20b4bfd6351267423ff5005ac3cb2e89dbb8f024cf60705d3f06a8a1309169a029eb5246ddc45a8d76464
diff --git a/dev-python/pexpect/pexpect-3.3.ebuild b/dev-python/pexpect/pexpect-3.3.ebuild
deleted file mode 100644
index 92cc05f97ccb..000000000000
--- a/dev-python/pexpect/pexpect-3.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
-HOMEPAGE="http://pexpect.sourceforge.net/ https://pypi.python.org/pypi/pexpect/ https://github.com/pexpect/pexpect/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples test"
-
-DEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- py.test tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}