summaryrefslogtreecommitdiff
path: root/dev-python/picklemagic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/picklemagic
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/picklemagic')
-rw-r--r--dev-python/picklemagic/Manifest3
-rw-r--r--dev-python/picklemagic/metadata.xml21
-rw-r--r--dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild30
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/picklemagic/Manifest b/dev-python/picklemagic/Manifest
new file mode 100644
index 000000000000..1ceca7e19bfd
--- /dev/null
+++ b/dev-python/picklemagic/Manifest
@@ -0,0 +1,3 @@
+DIST picklemagic-0.0_pre20160415.tar.xz 23364 BLAKE2B 07104393d41c68fabb26d642b6a78b5b5506322edc1322f6a0957c485c2681aafb388488b4d65d920102fb56839ebdeb82cbde909dae3d982311a3d776ca8aca SHA512 0b0866895df5f5f49462d75ad6a435f93796c60eae2442350ea0768872cc1938406b68f5ecb54e1583c245c6ac6d4feada32469184e24186adf78d002adfcd76
+EBUILD picklemagic-0.0_pre20160415.ebuild 691 BLAKE2B bddcc9abc86b0440f5ce1241ba24ed9a2b22baf12e7b77a3f953491705b5193da44bd945013ef82d634274f0fa4f1d59d941fd56ab6ce7c8c78586418c0c9bd9 SHA512 2bb379b51a18e1ce030990847c21a9a03d9c7872a5af684fa78876026283e0d712db6f4bb85fe6fb8e5838abadb658d229a64fc3fd2ea9b5edda5c7a2abc52be
+MISC metadata.xml 1089 BLAKE2B b649f7de5cb150c5f7e5d81b16d42f20ed9f5b94a4b071d788a7caf9d484c9fa1eef38fd6d0dcdac4b0399b7acd557b779ee263b9d22ec081d8845b5d3ce9d6b SHA512 02633df935ed2172dc10ebbc189bfc4385789520900d2147f7ae3a7ec10951f450cc720e487af93b85236548ad93f9402f4b36470ea1322ed15fab1c4efd3685
diff --git a/dev-python/picklemagic/metadata.xml b/dev-python/picklemagic/metadata.xml
new file mode 100644
index 000000000000..1027055fe7b1
--- /dev/null
+++ b/dev-python/picklemagic/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <longdescription>
+ A set of modules for analyzing and playing with the mechanics of python pickles.
+ Features:
+ * Forgiving: Extracts as much data as possible from the pickle, even if class definitions are unavailable.
+ * Safe: You can safely unpickle data structures from unknown sources
+ * Easy to use: Tools are provided which make it possible to code around the unpickled datastructures as if they were created from the actual class definitions.
+ * Customizeable: Most functionality is easily subclassable to suit your needs.
+ * Create pickles as if you were writing python: Via a few constructs it's possible to create custom pickles with the ease of writing normal python.
+ * Works in both python 2 and 3
+ </longdescription>
+ <upstream>
+ <remote-id type="github">CensoredUsername/picklemagic</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild b/dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild
new file mode 100644
index 000000000000..66c0a794e6ba
--- /dev/null
+++ b/dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+inherit python-r1
+
+SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="A library for analysing python pickles safely"
+HOMEPAGE="https://github.com/CensoredUsername/picklemagic"
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="doc"
+
+BDEPEND="doc? ( dev-python/sphinx )"
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_compile() {
+ use doc && emake -C doc html
+}
+
+src_install() {
+ default
+ python_foreach_impl python_domodule *.py
+ use doc && dodoc -r doc/build/html
+}