summaryrefslogtreecommitdiff
path: root/dev-python/piexif/piexif-1.1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/piexif/piexif-1.1.3-r1.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/piexif/piexif-1.1.3-r1.ebuild')
-rw-r--r--dev-python/piexif/piexif-1.1.3-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/piexif/piexif-1.1.3-r1.ebuild b/dev-python/piexif/piexif-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..8cc00f501540
--- /dev/null
+++ b/dev-python/piexif/piexif-1.1.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit edos2unix distutils-r1
+
+DESCRIPTION="Exif manipulation with pure Python"
+HOMEPAGE="https://github.com/hMatoba/Piexif
+ https://pypi.org/project/piexif/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/pillow[jpeg,${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+PATCHES=(
+ # From https://github.com/hMatoba/Piexif/pull/109
+ "${FILESDIR}"/${P}-tests-pillow-7.2.0.patch
+)
+
+src_prepare() {
+ edos2unix tests/s_test.py # to be able to patch it
+ default
+}
+
+python_test() {
+ "${PYTHON}" setup.py test || die
+}