summaryrefslogtreecommitdiff
path: root/dev-python/pikepdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/pikepdf
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/pikepdf')
-rw-r--r--dev-python/pikepdf/Manifest2
-rw-r--r--dev-python/pikepdf/pikepdf-1.13.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pikepdf/Manifest b/dev-python/pikepdf/Manifest
index 68a977e550be..9b11e14ce2d1 100644
--- a/dev-python/pikepdf/Manifest
+++ b/dev-python/pikepdf/Manifest
@@ -1,4 +1,6 @@
AUX pikepdf-1.8.3-test.patch 1383 BLAKE2B 18ac2e4ad4fd2c1e6db158ecd87505ef3099a5053d3d4b5b96a2b1179eeeb77218ba0582e1f25975f5f94867220fd382c82ca960da404154ea67008cd389ff82 SHA512 6db05c94c09f5474f53bd2dd77b0ebdf6cecb4cf00ae5c344b1795bd81379f072856c7d06c05630d40c878ba2fd9b09c918d0f6fe364b54fea720638135caf0c
+DIST pikepdf-1.13.0.tar.gz 2140229 BLAKE2B 886bb9395e8fa1105385908a06d076f78bb1712186a8cb0eafbe54d22a0c95fa2bc8eba8f2e3d60ec3b1392d550cd38c6486c601eba2ef167c718fa26b472f9e SHA512 48304f85e73148dbcfae50ecc5767686b46ce9d44b13eb3f991ab3b358b99208383627abdb5ef3c17cf31a422872ea0bae7560e9c7c36130c6009563b6169f4d
DIST pikepdf-1.8.3.tar.gz 1649370 BLAKE2B c655eb2a9304eb624b5f3dd3ea68ff3194f5a508b4249ef0643689945c28bbe9eaad015df481516d6cfce6768a70a34377725a7995b448f22a2eb025b4967e71 SHA512 5cb674042dca6850df7cf9476743956967d0ad168ac6bdadda03895a604f6c3670849e33ab863e7686eaa46922489d6dd1da9883d19a721c8021323d768086a9
+EBUILD pikepdf-1.13.0.ebuild 1485 BLAKE2B 617c0d51888b58058446013d346f15eb1169a3b3bf90afbac3d6d6814766d5ae3416eebf24ad13470bc10c64269c9d35ce6dfd216e668d447339eaf57bbde637 SHA512 f9fa0b061e0801a0321edd80f4a7ab28305dfaa687fedfe0f559cf96a0edbbb06b50751a32093a0712446c76eaccffd9d38a672d3b9018cf71410593c802047f
EBUILD pikepdf-1.8.3.ebuild 1476 BLAKE2B a8b6d92586c808f85d173962fd138d70a0f4385ba6227ad1e679bbbaee5929c035c4f9b22b821fe7113910ee056c28ef8c96b3272edf984b51ec54d57c3ebcf1 SHA512 54281c35dedb20e9e17716d27f49690baafae3f32cbb15f35d20acb09b2e3618d7cc457bc4f46755bc6519ee946ecbe0f90515007cd71834db9580d70e915ecd
MISC metadata.xml 579 BLAKE2B 010d66d2d00284f744a85bebf5b916e77efc7f46f880886815bc677007ae0f71b5f19b6caf6cc49c05e1e9ce13c954876e8d13b988a533af2fb68de147e6911a SHA512 3f41579208b5354e6361d6cd1f035bf0e5819fd90575e15c684cf501ca33bc14b6c4a7b70040cd5f44796a8ca58810535734787ce84ce8183d0cadc14d6c1f01
diff --git a/dev-python/pikepdf/pikepdf-1.13.0.ebuild b/dev-python/pikepdf/pikepdf-1.13.0.ebuild
new file mode 100644
index 000000000000..2a6d6256b508
--- /dev/null
+++ b/dev-python/pikepdf/pikepdf-1.13.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with pdf files based on qpdf"
+HOMEPAGE="https://pypi.org/project/pikepdf/ https://github.com/pikepdf/pikepdf"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/qpdf
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ test? ( >=dev-python/attrs-19.1.0
+ >=dev-python/hypothesis-4.24
+ <dev-python/hypothesis-5.3.5
+ >=dev-python/pillow-5.0.0
+ >=dev-python/pytest-4.4.0
+ <dev-python/pytest-5.3.5
+ >=dev-python/pytest-xdist-1.28
+ <dev-python/pytest-xdist-2.0
+ >=dev-python/pytest-helpers-namespace-2019.1.8
+ >=dev-python/pytest-timeout-1.3.3
+ >=dev-python/python-xmp-toolkit-2.0.1 )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.8.3-test.patch )
+
+python_test() {
+ pytest
+}
+
+# When ipython and matplotlib will get python3_8 support, we'll be able to add
+#
+#IUSE="doc"
+#DEPEND="doc? ( dev-python/ipython
+# dev-python/matplotlib
+# dev-python/sphinx-1.4
+# dev-python/sphinx_rtd_theme )"
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+#python_install_all() {
+# use doc && local HTML_DOCS=( docs/_build/html/. )
+# distutils-r1_python_install_all
+#}