summaryrefslogtreecommitdiff
path: root/dev-python/pilkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pilkit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pilkit')
-rw-r--r--dev-python/pilkit/Manifest3
-rw-r--r--dev-python/pilkit/metadata.xml23
-rw-r--r--dev-python/pilkit/pilkit-2.0.ebuild28
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pilkit/Manifest b/dev-python/pilkit/Manifest
new file mode 100644
index 000000000000..4a77287101c5
--- /dev/null
+++ b/dev-python/pilkit/Manifest
@@ -0,0 +1,3 @@
+DIST pilkit-2.0.tar.gz 160077 BLAKE2B def84c3444c5ffe7e1b9c016c2fe15de222d6765e7ce4652ef2f6864af59fdc89b9bde5c7a63097838ab3fc054c81529dcb4a13cd3fb3ee8a0f141f6b0030c10 SHA512 7732c67bc00db53c6849c907233381cca7f9055d55d479958a7b97db277524ac280753fd40c0023fe2b34f98b7261134f993585e658275ccd4c67f357c13de51
+EBUILD pilkit-2.0.ebuild 685 BLAKE2B b62d1088828b5971fb48ae2fe992adf7495f4f417723facd6d32733626850b75a4d822fc334a4fd0894a35ac714646585dd053e1c6ba7212e7dc9728e27fde5c SHA512 07e411036850db3096e4b978a5d4820187a771693433ec8be30dd751085e84ec3849a6b07cd8d699786d53c4f0d2db31ecfbf0a9538cdc9ea2fac6b51ef7554d
+MISC metadata.xml 707 BLAKE2B 4499ba1535c6f7572d0e336ccb8b69eebc7d52c0a26fe3a113d79f22bdf93b33062cab1d8f5735d795d6c11c0164bf7304b8327c1e4724e2f9d8c572079ff508 SHA512 32ae881094153b9179401cc55abc4a03469d9004b121afad62bdcbe80725c687f5779fcb3e2286c051f6038e98f7838d89308f12fba4c0fb15e5abe6e27df556
diff --git a/dev-python/pilkit/metadata.xml b/dev-python/pilkit/metadata.xml
new file mode 100644
index 000000000000..b4d5770a92d6
--- /dev/null
+++ b/dev-python/pilkit/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>thomas@gstaedtner.net</email>
+ <name>Thomas Gstädtner</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pilkit</remote-id>
+ <remote-id type="github">matthewwithanm/pilkit</remote-id>
+ <bugs-to>
+ https://github.com/matthewwithanm/pilkit/issues
+ </bugs-to>
+ </upstream>
+ <longdescription>
+ PILKit is a collection of utilities for working with
+ PIL (the Python Imaging Library).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pilkit/pilkit-2.0.ebuild b/dev-python/pilkit/pilkit-2.0.ebuild
new file mode 100644
index 000000000000..432c223564bc
--- /dev/null
+++ b/dev-python/pilkit/pilkit-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of utilities and processors for the Python Imaging Libary"
+HOMEPAGE="https://github.com/matthewwithanm/pilkit"
+SRC_URI="https://github.com/matthewwithanm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ nosetests --verbose || die
+}