summaryrefslogtreecommitdiff
path: root/dev-python/pillow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-04 11:22:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-04 11:22:15 +0100
commit7f6382ebb44b75c53021d4c4ab77d6b34aed21ac (patch)
tree4d92ef3af5a26ff8a8a5a1ec4f21d18c65f56fe2 /dev-python/pillow
parent41e5b5c1f11820df590e0a245bbddf224bc07823 (diff)
gentoo auto-resync : 04:04:2023 - 11:22:14
Diffstat (limited to 'dev-python/pillow')
-rw-r--r--dev-python/pillow/Manifest2
-rw-r--r--dev-python/pillow/pillow-9.4.0.ebuild130
2 files changed, 0 insertions, 132 deletions
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index dbbb15c75cf9..618260d0f5f3 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -1,5 +1,3 @@
-DIST pillow-9.4.0.gh.tar.gz 50412873 BLAKE2B 12003b8b9e582c47b45d82f4a10553e376dcb38e65154eca5753b2908d6ecad10fc732d622856c7742fb413abbf4afc926e3d30e1e9e410e966f18da4ddde6c1 SHA512 6c08336e5ca1e652bb3237ae092be61b78dc1cf65603d6b23369eb8e0554786114a8f87ab092a5fb9577e02cd0bb381353fa657e03090baeb91b4b8e3c740d51
DIST pillow-9.5.0.gh.tar.gz 50491974 BLAKE2B 663c14b89ddd1e2d49872994033a04e500d0b6eccbb8d6ce094f58ae1aaf3f215e9984f2afeb43fb83e0c3c93af1150beeb7d5f0abb77c59087901b53fd24e37 SHA512 da0c7a1bde4741ced168c013fdc7afa8af1100bba878bdaeeb9804fed4dcf70c07ed62004ab2c73694eae3d28e2d72d46c155f78b540075aafb36c8e7a5649ff
-EBUILD pillow-9.4.0.ebuild 3362 BLAKE2B 6fccf270776d72312006668c36082cc7c93460c7cec31609440bf13bfd0ce1f2654c93e55f49aa29224a6c90f8118634e98902ac2790597ec593843e63b781c4 SHA512 6142e5ea001d076ae56e08486cf3c839532c0f01779ef2949d09b3d8aaa3ac1d54c036d3727ed3aa08b5b500aaef4349554792d2672772b6cf84f5e88dda4e6f
EBUILD pillow-9.5.0.ebuild 3362 BLAKE2B 6fccf270776d72312006668c36082cc7c93460c7cec31609440bf13bfd0ce1f2654c93e55f49aa29224a6c90f8118634e98902ac2790597ec593843e63b781c4 SHA512 6142e5ea001d076ae56e08486cf3c839532c0f01779ef2949d09b3d8aaa3ac1d54c036d3727ed3aa08b5b500aaef4349554792d2672772b6cf84f5e88dda4e6f
MISC metadata.xml 480 BLAKE2B b42e6b01b1572a0688ef93025a0baaa95b9fd0c3a5eabcddcea7145dd880a95f11859b255ae24a376ca792559ffcf940c67da1b19f2f579dbc6ef6de68903749 SHA512 b98a33136aef4498051370bce3295b000687ddb80b4d909b26b32af61b4e4638d07269f7924ae039420af63236aa74b51e23d2feae1c83349683073c69714582
diff --git a/dev-python/pillow/pillow-9.4.0.ebuild b/dev-python/pillow/pillow-9.4.0.ebuild
deleted file mode 100644
index 6c245bd70d77..000000000000
--- a/dev-python/pillow/pillow-9.4.0.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-PYTHON_REQ_USE='tk?,threads(+)'
-
-inherit distutils-r1 toolchain-funcs virtualx
-
-MY_PN=Pillow
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python Imaging Library (fork)"
-HOMEPAGE="
- https://python-pillow.org/
- https://github.com/python-pillow/
- https://pypi.org/project/Pillow/
-"
-SRC_URI="
- https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="examples imagequant +jpeg jpeg2k lcms test tiff tk truetype webp xcb zlib"
-REQUIRED_USE="test? ( jpeg jpeg2k lcms tiff truetype )"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- imagequant? ( media-gfx/libimagequant:= )
- jpeg? ( media-libs/libjpeg-turbo:= )
- jpeg2k? ( media-libs/openjpeg:2= )
- lcms? ( media-libs/lcms:2= )
- tiff? ( media-libs/tiff:=[jpeg,zlib] )
- truetype? ( media-libs/freetype:2= )
- webp? ( media-libs/libwebp:= )
- xcb? ( x11-libs/libxcb )
- zlib? ( sys-libs/zlib:= )
-"
-RDEPEND="
- ${DEPEND}
- dev-python/olefile[${PYTHON_USEDEP}]
-"
-BDEPEND="
- virtual/pkgconfig
- test? (
- ${RDEPEND}
- dev-python/defusedxml[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- || (
- media-gfx/imagemagick[png]
- media-gfx/graphicsmagick[png]
- )
- )
-"
-
-EPYTEST_DESELECT=(
- # TODO; incompatible Qt version?
- Tests/test_qt_image_qapplication.py::test_sanity
-)
-
-usepil() {
- usex "${1}" enable disable
-}
-
-python_configure_all() {
- # It's important that these flags are also passed during the install phase
- # as well. Make sure of that if you change the lines below. See bug 661308.
- cat >> setup.cfg <<-EOF || die
- [build_ext]
- disable_platform_guessing = True
- $(usepil truetype)_freetype = True
- $(usepil jpeg)_jpeg = True
- $(usepil jpeg2k)_jpeg2000 = True
- $(usepil lcms)_lcms = True
- $(usepil tiff)_tiff = True
- $(usepil imagequant)_imagequant = True
- $(usepil webp)_webp = True
- $(usepil webp)_webpmux = True
- $(usepil xcb)_xcb = True
- $(usepil zlib)_zlib = True
- EOF
-
- # setup.py won't let us add the right toolchain paths but it does
- # accept additional ones from INCLUDE and LIB so set these. You
- # wouldn't normally need these at all as the toolchain should look
- # here anyway but it doesn't for this setup.py.
- export \
- INCLUDE="${ESYSROOT}"/usr/include \
- LIB="${ESYSROOT}"/usr/$(get_libdir)
-
- # We have patched in this env var.
- tc-export PKG_CONFIG
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO (is clipboard unreliable in Xvfb?)
- Tests/test_imagegrab.py::TestImageGrab::test_grabclipboard
- )
-
- "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
- # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
- epytest -p no:relaxed || die "Tests failed with ${EPYTHON}"
-}
-
-python_install() {
- python_doheader src/libImaging/*.h
- distutils-r1_python_install
-}
-
-python_install_all() {
- if use examples ; then
- docinto example
- dodoc docs/example/*
- docompress -x /usr/share/doc/${PF}/example
- fi
- distutils-r1_python_install_all
-}