summaryrefslogtreecommitdiff
path: root/dev-python/pipenv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-03 08:30:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-03 08:30:30 +0000
commiteaab68ba6a05bc57d98ca12032440835ef905326 (patch)
tree722637b4f6d0087c5b321ceb515a98913bee7559 /dev-python/pipenv
parent4650985dd0e898b82e0d2ec225931297d4fadccf (diff)
gentoo resync : 03.02.2018
Diffstat (limited to 'dev-python/pipenv')
-rw-r--r--dev-python/pipenv/Manifest1
-rw-r--r--dev-python/pipenv/pipenv-9.0.0-r1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pipenv/Manifest b/dev-python/pipenv/Manifest
index fbc9a50f89e0..79fcc263cbcb 100644
--- a/dev-python/pipenv/Manifest
+++ b/dev-python/pipenv/Manifest
@@ -1,3 +1,4 @@
DIST pipenv-9.0.0.tar.gz 3859618 BLAKE2B 138e53b1ef08d036f4ded6b4ca9da1a88084ad3d987aea1c6783181de414f7b24a54d46b26c2171f0918a1b1c22e2dac983fafad8a80f4aa95f93979bebfe2df SHA512 ea2d5ada73288a5d20473d769e20d6d195f65c3d3aebe2e52a43e1641af916295a18810bdb74a611751e773bfdfbc0ea7190d61358dce66d4aa33fa4a6f6131f
+EBUILD pipenv-9.0.0-r1.ebuild 895 BLAKE2B 434565b6d6e2790b035fdce4e6b16602f5e2c2e9b97546ffa0da4eb1231a7004191e5ef7a8683d54fa0b6bac68868bc4c186a0b8b42f528603335be838ac6b57 SHA512 3287e23fa088a20597070f0d67d66d59ac0d4c71f645f1abe1ee2c2c514df52fc268c1e8c74055c5d724e17b30f50b610a1f81d5f4849f608b44371e541156a7
EBUILD pipenv-9.0.0.ebuild 907 BLAKE2B ac5794216c0addf10ada0159008645ebbbfac13251c2647ca464658c1f0bc5f4d43543c18eb4554d3b3ccfe95800cfd8a83be46fca6591daa246cb288199c4af SHA512 c9f7093996d0d0dcd16d1731b490e260cb68900334d860b4902ee0901ec34c6bd3375d1faaf85826879563ad5786314c556642df3742585ed45cee9ec6326a5b
MISC metadata.xml 445 BLAKE2B 71ce759695adf862ea00805dc1865487ae2b4bccd94af567240463b8935463010c4c8945fe3ba58a216afae1066de9b8659ea0ec216128c9017ec42e52bed3c9 SHA512 15d259d0f38fbee2fb0d9765934eddc46c8bb1a6da7fc656f3b2b006c74aa1b0ffd8211e9d9c23f241113a8ae3a333708acbf351fa1a150084b127b4eab88795
diff --git a/dev-python/pipenv/pipenv-9.0.0-r1.ebuild b/dev-python/pipenv/pipenv-9.0.0-r1.ebuild
new file mode 100644
index 000000000000..fd2719415128
--- /dev/null
+++ b/dev-python/pipenv/pipenv-9.0.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Development Workflow for Humans"
+HOMEPAGE="https://github.com/pypa/pipenv https://pypi.python.org/pypi/pipenv"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/flake8-3.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pew-0.1.26[${PYTHON_USEDEP}]
+ >=dev-python/pip-9.0.1[${PYTHON_USEDEP}]
+ >dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# not completely packed
+# requires networking
+RESTRICT="test"
+
+python_test() {
+ py.test -v -v || die
+}