summaryrefslogtreecommitdiff
path: root/dev-python/pipfile/pipfile-0.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pipfile/pipfile-0.0.2.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pipfile/pipfile-0.0.2.ebuild')
-rw-r--r--dev-python/pipfile/pipfile-0.0.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pipfile/pipfile-0.0.2.ebuild b/dev-python/pipfile/pipfile-0.0.2.ebuild
new file mode 100644
index 000000000000..ec951ea5c9f7
--- /dev/null
+++ b/dev-python/pipfile/pipfile-0.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Replacement for the existing standard pip's requirements.txt file"
+HOMEPAGE="https://github.com/pypa/pipfile"
+SRC_URI="https://github.com/pypa/pipfile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+RDEPEND="dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# no tests in this release
+RESTRICT="test"
+
+# master has pytest tests
+distutils_enable_tests pytest