summaryrefslogtreecommitdiff
path: root/dev-python/pkgcraft
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-30 05:39:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-30 05:39:05 +0100
commit49fadb6686800eac5ce039896df6437ac7240c8c (patch)
treebb8d772a99971082b6958d589874e7db938cd2ca /dev-python/pkgcraft
parenta55dc4dc2b72859e439db575f57f02ce4ba700f1 (diff)
gentoo auto-resync : 30:09:2023 - 05:39:05
Diffstat (limited to 'dev-python/pkgcraft')
-rw-r--r--dev-python/pkgcraft/Manifest4
-rw-r--r--dev-python/pkgcraft/pkgcraft-0.0.7.ebuild81
-rw-r--r--dev-python/pkgcraft/pkgcraft-9999.ebuild2
3 files changed, 85 insertions, 2 deletions
diff --git a/dev-python/pkgcraft/Manifest b/dev-python/pkgcraft/Manifest
index 692262374396..b8bdbf700cb1 100644
--- a/dev-python/pkgcraft/Manifest
+++ b/dev-python/pkgcraft/Manifest
@@ -1,4 +1,6 @@
DIST pkgcraft-0.0.6.tar.gz 406538 BLAKE2B 5c90b57cb11e9f754cd695989994b3a9be52007482981c997f2e361fbbb72aeb0810d7f41dea1cdcd74c47840bb1c3b2cf225c967ba76b01769da93f909d9911 SHA512 ddd7bf77a3509156e8c16e5aeeb94a5f4530d9d1a3e6617d3974adfae7b46f0b0d31f4828dbd70261b42c883e776bf7572ca2fe8e23c9216637d886b9d8811cc
+DIST pkgcraft-0.0.7.tar.gz 406608 BLAKE2B 733876723c676ac0000699440955518bb8a2fb35cc5bb1664e791c2be172a8a4ce90faff849eeacf293e4071dee0bb6b5ae18a5dba0c04ee79b52c1153c5b8d1 SHA512 e01cce2e5840a84ab43b6f9e9c0c15caa0d5247ff85e7bac4452411cccc87eea88193e12585bfebd01b73aa27f4c1d1f0e72982f61270f894890be9b38961e3e
EBUILD pkgcraft-0.0.6.ebuild 2012 BLAKE2B 2414b04006aa23a6e1888118f306f0fb5286046c462ae307a143195373d0e7da7741580a2db4d84f9958d8a1ed412b5bb0b4214b9bdd7bbcf44dd01d725d0e28 SHA512 18262f24524878ddb7112c582295f74c10f5e52eb4a0f1fe64016d150f6271b89a85ebf3eb482034408641cdaa1a86a1b1a8d697f1a588db3faade8aa7197cfc
-EBUILD pkgcraft-9999.ebuild 2012 BLAKE2B 2414b04006aa23a6e1888118f306f0fb5286046c462ae307a143195373d0e7da7741580a2db4d84f9958d8a1ed412b5bb0b4214b9bdd7bbcf44dd01d725d0e28 SHA512 18262f24524878ddb7112c582295f74c10f5e52eb4a0f1fe64016d150f6271b89a85ebf3eb482034408641cdaa1a86a1b1a8d697f1a588db3faade8aa7197cfc
+EBUILD pkgcraft-0.0.7.ebuild 2012 BLAKE2B 80705b5b983927722487830a000987c0d419794ce101490314cc7ee3665497f078c0cc448257e3a7e07c1faf4da3074b9bfa1cb3a53b28eea6a6b66222cf2815 SHA512 ad89a4ea61dd201669a067ce8a87aa3cde5aeabf54954d1d583ff83679fbb008c8ff0ddc277022f0aef0b67dc3bfb3e659f96a20da2fcfd0364cc9f3183e5776
+EBUILD pkgcraft-9999.ebuild 2012 BLAKE2B 80705b5b983927722487830a000987c0d419794ce101490314cc7ee3665497f078c0cc448257e3a7e07c1faf4da3074b9bfa1cb3a53b28eea6a6b66222cf2815 SHA512 ad89a4ea61dd201669a067ce8a87aa3cde5aeabf54954d1d583ff83679fbb008c8ff0ddc277022f0aef0b67dc3bfb3e659f96a20da2fcfd0364cc9f3183e5776
MISC metadata.xml 454 BLAKE2B 5085311aaebe3c2cc696fee5da4ee272e47936a4f729c2007efce94097087a987985fb972df477fb72eead3402555924ca8b8f183b69af357453ad93daeb946e SHA512 ba7457ec4b43f1664042599d4e23506e496d1f2212ea7aa02c58fd9d796915dace2817bfb1c71e6f022e9490215248e2a705b223a087d91255b97b23f82f9c23
diff --git a/dev-python/pkgcraft/pkgcraft-0.0.7.ebuild b/dev-python/pkgcraft/pkgcraft-0.0.7.ebuild
new file mode 100644
index 000000000000..c5c9bca81ac1
--- /dev/null
+++ b/dev-python/pkgcraft/pkgcraft-0.0.7.ebuild
@@ -0,0 +1,81 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for pkgcraft"
+HOMEPAGE="
+ https://pypi.org/project/pkgcraft/
+ https://github.com/pkgcraft/pkgcraft-python/
+"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcraft/pkgcraft-python.git"
+ inherit git-r3
+
+ PKGCRAFT_VERSION_MAX="99999" # extra 9 here or 9999 isn't mergable per DEPEND below
+ PKGCRAFT_VERSION_MIN="9999"
+else
+ SRC_URI="https://github.com/pkgcraft/pkgcraft-python/releases/download/v${PV}/${P/-python}.tar.gz"
+ S="${WORKDIR}"/${P/-python}
+
+ KEYWORDS="~amd64 ~arm64"
+
+ PKGCRAFT_VERSION_MAX="9999"
+ PKGCRAFT_VERSION_MIN="0.0.12"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+examples"
+
+DEPEND="
+ <sys-libs/pkgcraft-${PKGCRAFT_VERSION_MAX}
+ >=sys-libs/pkgcraft-${PKGCRAFT_VERSION_MIN}:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if [[ ${PV} != 9999 ]] ; then
+ local actual_pkgcraft_min=$(sed -En '/^MIN_VERSION =/{s/[^0-9.]//gp}' setup.py || die)
+ if [[ ${actual_pkgcraft_min} != ${PKGCRAFT_VERSION_MIN} ]] ; then
+ eerror "Expected minimum pkgcraft-c version: ${PKGCRAFT_VERSION_MIN}"
+ eerror "Actual minimum pkgcraft-c version: ${actual_pkgcraft_min}"
+ die "Mismatch between setup.py's MIN_VERSION and ebuild!"
+ fi
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_install() {
+ # Conditional because these aren't installed officially right now
+ # and the naming is just for convenience.
+ if use examples ; then
+ while IFS= read -r -d '' file ; do
+ python_newexe "${S}"/examples/${file##*/} pkgcraft-${file##*/}
+ done < <(find "${S}"/examples -type f -executable -print0 || die)
+ fi
+
+ distutils-r1_python_install
+}
diff --git a/dev-python/pkgcraft/pkgcraft-9999.ebuild b/dev-python/pkgcraft/pkgcraft-9999.ebuild
index 204a8185dbfb..c5c9bca81ac1 100644
--- a/dev-python/pkgcraft/pkgcraft-9999.ebuild
+++ b/dev-python/pkgcraft/pkgcraft-9999.ebuild
@@ -28,7 +28,7 @@ else
KEYWORDS="~amd64 ~arm64"
PKGCRAFT_VERSION_MAX="9999"
- PKGCRAFT_VERSION_MIN="0.0.11"
+ PKGCRAFT_VERSION_MIN="0.0.12"
fi
LICENSE="MIT"