summaryrefslogtreecommitdiff
path: root/dev-python/pkginfo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-04 02:07:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-04 02:07:22 +0000
commit38ecaf88ae0891dd2d7f2bdd9a7acdcd45835724 (patch)
tree9416e00c684e43c1731a2189865034d568f2a20f /dev-python/pkginfo
parent7f4b508a2da3c371c7e770aa6ab83b0c4237cd1c (diff)
gentoo auto-resync : 04:12:2024 - 02:07:22
Diffstat (limited to 'dev-python/pkginfo')
-rw-r--r--dev-python/pkginfo/Manifest4
-rw-r--r--dev-python/pkginfo/pkginfo-1.11.3.ebuild28
-rw-r--r--dev-python/pkginfo/pkginfo-1.12.0.ebuild28
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
index 1686e21c4dc4..23c8fc52e38f 100644
--- a/dev-python/pkginfo/Manifest
+++ b/dev-python/pkginfo/Manifest
@@ -1,3 +1,7 @@
DIST pkginfo-1.11.2.tar.gz 450821 BLAKE2B 4ff042c829bc123e3ccb5ab768f9cdee29f085037baa9a10c773f6c7bc544a089b6be6ec6c9caf4e4919305106c6ccfaa5f3bbcc8c3322bf4c088a1a0b3e2e3a SHA512 2a7bb31a6d46bb28242fa668dc063c3e0be565ea2f011e051676779f530d2a206d595013512b12e4e10eb94cf522277347d085c8a8e29fe331d9049e370f2bdc
+DIST pkginfo-1.11.3.tar.gz 450996 BLAKE2B 58edcc1b6395496edc7f5f300ca8e5ab17e9a1d94f315c43d175d60ede01d153b14ff02f7de19cdb3ac8ca6b672d06856432e5deb4a2911cb86034d0cb7fbb92 SHA512 c54f791a577d241a22427a1cfae25d24b5f6b35462f0b0bcb4d7b6713f0833f4058cfdee15659c988191ff411e8bcad1c261abca5e4cc35ddf024d50a7bcb382
+DIST pkginfo-1.12.0.tar.gz 451375 BLAKE2B 4a0e30c71c7ce283f16fb8595343ac7f473ce604e47a4863cc107cab96db1db9de0eb1c6ccd9430cea1eb6b94903f00356d75c5b9acfa50129d9c4c7ee24577d SHA512 871d85cfbc69380033dc071bfb32dc3da4a5c44fefda8c3be9c7ae5d8ed17f2800f82f9ce3b81e4c0ebb3a1956581093a1379d00a9eb6a42e0821253586aaceb
EBUILD pkginfo-1.11.2.ebuild 623 BLAKE2B b3e7c21d66209765ac016e73519e7bf6b8c6872084baeec51b1657dad616e7f5dd572e0507cc50e2526009e7bc10ef0c01b57bdeb4b73ba054f4de8239ad4477 SHA512 e60454455cb30b618024af5c40ef4a3099cfad7307f5e8749210e0c3736ed5b7dde8905756424f9d0716eb668e8b01c665da40016e2f140d0d139bc84d6b1a54
+EBUILD pkginfo-1.11.3.ebuild 631 BLAKE2B 1fa5bc665b029d6fb14f7f6e55deccc696cf34a6ec3276a966bbea681ec7fcc06adc134ace93d22672e806305c68b287058331a6874b51250bbf83e11f04b240 SHA512 c5f8394de6ea206ae7eaf518dacfe18c1bdedf38f5dac641616a4541e3d94514aaa01fd1ee557c5ad962f9a65d293a7e9abd130b0f1333cc163bcdc0c7f4fc27
+EBUILD pkginfo-1.12.0.ebuild 631 BLAKE2B 1fa5bc665b029d6fb14f7f6e55deccc696cf34a6ec3276a966bbea681ec7fcc06adc134ace93d22672e806305c68b287058331a6874b51250bbf83e11f04b240 SHA512 c5f8394de6ea206ae7eaf518dacfe18c1bdedf38f5dac641616a4541e3d94514aaa01fd1ee557c5ad962f9a65d293a7e9abd130b0f1333cc163bcdc0c7f4fc27
MISC metadata.xml 385 BLAKE2B da3779a71a7d23a535599d8854c970725b3e6c121642cfabbabccc0e97cc1dab0cf77452da565c9efbd8044cb02cb2fbe00687a0b312948298902e4eb1f4e498 SHA512 fcd65e87146d573c1bc33dc560ed419ae5d4e46e6ba423da1a6dd46ce96683d3ffeef75b640ee671f16865e34293695b48a5fef89ee754a8b6bb797a03c13b08
diff --git a/dev-python/pkginfo/pkginfo-1.11.3.ebuild b/dev-python/pkginfo/pkginfo-1.11.3.ebuild
new file mode 100644
index 000000000000..f46173de33c7
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.11.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="
+ https://launchpad.net/pkginfo/
+ https://pypi.org/project/pkginfo/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
diff --git a/dev-python/pkginfo/pkginfo-1.12.0.ebuild b/dev-python/pkginfo/pkginfo-1.12.0.ebuild
new file mode 100644
index 000000000000..f46173de33c7
--- /dev/null
+++ b/dev-python/pkginfo/pkginfo-1.12.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="
+ https://launchpad.net/pkginfo/
+ https://pypi.org/project/pkginfo/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs