summaryrefslogtreecommitdiff
path: root/dev-python/plette/plette-0.4.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-19 07:53:50 +0000
commit32b8124b0a5827960601f2183a970103b3d231b7 (patch)
treefebd1cb81d2417f5452d0e21f81d06663f12caa3 /dev-python/plette/plette-0.4.4-r2.ebuild
parent89e7f1cd6dd17f245898939477ef38d45dd112b9 (diff)
gentoo auto-resync : 19:12:2023 - 07:53:49
Diffstat (limited to 'dev-python/plette/plette-0.4.4-r2.ebuild')
-rw-r--r--dev-python/plette/plette-0.4.4-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/plette/plette-0.4.4-r2.ebuild b/dev-python/plette/plette-0.4.4-r2.ebuild
new file mode 100644
index 000000000000..1a12a8b3c05e
--- /dev/null
+++ b/dev-python/plette/plette-0.4.4-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Structured Pipfile and Pipfile.lock models"
+HOMEPAGE="
+ https://github.com/sarugaku/plette
+ https://pypi.org/project/plette/
+"
+# pypi tarballs are missing test data
+SRC_URI="https://github.com/sarugaku/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/cerberus[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest