summaryrefslogtreecommitdiff
path: root/dev-python/pluginbase
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/pluginbase
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/pluginbase')
-rw-r--r--dev-python/pluginbase/Manifest2
-rw-r--r--dev-python/pluginbase/pluginbase-0.5.ebuild42
2 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/pluginbase/Manifest b/dev-python/pluginbase/Manifest
index b559a6180f5e..f93a8b876d4c 100644
--- a/dev-python/pluginbase/Manifest
+++ b/dev-python/pluginbase/Manifest
@@ -1,5 +1,3 @@
-DIST pluginbase-0.5.tar.gz 41964 BLAKE2B 84fc187b60182f100a9016ac663856b29587e60b5ef5ac9c51fb4ed99666908a77c9817c2dc5fb64e82b807e635bd10beb5ce7644e31e63262736cc667a7b8c2 SHA512 921ddc7dacb6ad63abc90beb1d1d993e7b15c9cfe21e850a5852eb40735436e08b39fd2a6d83e23f641014ee81e718aca147ef1e21b55f94ce04a64ba7780455
DIST pluginbase-1.0.0.tar.gz 41795 BLAKE2B 68d7704b52db39af4f0c2e1f790802eb5f2fd15d91726752605901b3e8a3c736204fad93d96b5dd1a4199586b4d9b42895cbe8290acaed1b4051e8103efb43f9 SHA512 95c3b770980fa5ec745b8d788df29c6219ed6e5af7666f9830d56c6acae01f90831655127bcef69b2dfc423d09429373ae7d4c8b45c76c62a41f909d0747c0a0
-EBUILD pluginbase-0.5.ebuild 935 BLAKE2B 27bf1cfdd73c8264d07f7a4934ca521699192b8908335201a87eb56a12d3b9230f5eb4df407bb69621b24ee21fe02d6ecb72c63c7c9a4c631fb6801ca6d4b3e3 SHA512 1150ca5bcc39e7ff05ab78687417663ae1ba13fcba7f701479605da0162ba84508205e2c89bc50a9298c0c06c0adab1578cbee914532ae2d62555b1a0875699c
EBUILD pluginbase-1.0.0.ebuild 931 BLAKE2B 6ee3880edfb0760347a590982827f5c1c3335c34256875424cd18a2a2f0da2b5ba409c447a65968c742fe394e32b1c7536cd114cc5c91d890f076d08bf73768f SHA512 f32fa8efdb45e93ba0391001eef6ce4e858e51018f74d9cbbcfb3702b5d7780f0f2b9b8ffef378dc72822ef0e40d879782d11a815a1a40759cb424e405c8f512
MISC metadata.xml 385 BLAKE2B 0b58f71f7f6e816ba3b2c41212f371d37b0b09b38fc69a1adcdbab7a4537f9e9e7c5c0d9505e5dc72d219f30aeb5a3739c7f58bf4927f75323bd2b34e25733dd SHA512 166cec1bf4ad16e00b937dca860dedef5f8f766c1e3edae03dd29753ad9590843601723243e702344d1d4853b4d1a87c9c0960f9b70ac3dd4ad40995333516b2
diff --git a/dev-python/pluginbase/pluginbase-0.5.ebuild b/dev-python/pluginbase/pluginbase-0.5.ebuild
deleted file mode 100644
index 1269425a52e6..000000000000
--- a/dev-python/pluginbase/pluginbase-0.5.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 python3_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Support library for building plugins sytems in Python"
-HOMEPAGE="https://github.com/mitsuhiko/pluginbase"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_prepare_all() {
- sed -e "s/, 'sphinx.ext.intersphinx'//" \
- -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- cd tests && PYTHONPATH=.. py.test --tb=native || die "Tests fail with ${EPYTHON}"
-}