summaryrefslogtreecommitdiff
path: root/dev-python/podman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-14 07:56:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-14 07:56:51 +0000
commit2e4747a36a51fd58c21f3f00db959709e83fe08b (patch)
tree55b3fa7393c53b4b2fa2bb96fdae27d9d4444a97 /dev-python/podman
parent5c1e419582680cfb61e0ae777c693704f3a731e1 (diff)
gentoo auto-resync : 14:02:2023 - 07:56:50
Diffstat (limited to 'dev-python/podman')
-rw-r--r--dev-python/podman/Manifest3
-rw-r--r--dev-python/podman/metadata.xml16
-rw-r--r--dev-python/podman/podman-4.4.0.ebuild52
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/podman/Manifest b/dev-python/podman/Manifest
new file mode 100644
index 000000000000..17207d29ca20
--- /dev/null
+++ b/dev-python/podman/Manifest
@@ -0,0 +1,3 @@
+DIST podman-py-4.4.0.gh.tar.gz 177587 BLAKE2B 92d2a45a20304be648247fe8c95ab7ed84795e419d79fc731a6be4f228851b10324546b9cd14f9235a3972fd9258d50b2512216121c0fef59c0eb66d7c12c91c SHA512 47b4157fd9e6d54171f6f970012e828f877c66c4fabe4f30ad93974945b9e35fa7084c2908efca42c8b71a8d9f25e7a29a624152ce7bea1eebafcaa3700cb967
+EBUILD podman-4.4.0.ebuild 1136 BLAKE2B 95a4e548de829cc240f8b20d404b8c49d55e5ecad211933e4c42984a900b84bdde719d4fb9e99314ab27b0c5da6cf79f8a95d43332be892f2320891049adaab7 SHA512 221edd3805d5cfb184d391ed1daa1880ae5cefa93aef5e761fef52b5c766868a006a2c4303bfbc156ceb9951eb25d0074f6f2dc72f5bdb7de377e9d8da5f9d2d
+MISC metadata.xml 475 BLAKE2B 42fc2c044df94ebf8a4eb5088a39ad3075089cd5a007473db0964df4efb8c7a437c94db9c161d6ba81d2c017377919861f17b7fe3e133aa597312cad2df012f4 SHA512 017f54ebf56fc59c14ff0e9c2f15b899556ff3d512d22ed2abc35227c079ec64c8eb855f60e65299abd7f8b5433b2268dc7c2e428476efc334e24f0d90181bc8
diff --git a/dev-python/podman/metadata.xml b/dev-python/podman/metadata.xml
new file mode 100644
index 000000000000..6dcf1a50ca47
--- /dev/null
+++ b/dev-python/podman/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">containers/podman-py</remote-id>
+ <remote-id type="pypi">podman</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/podman/podman-4.4.0.ebuild b/dev-python/podman/podman-4.4.0.ebuild
new file mode 100644
index 000000000000..843534a57bf8
--- /dev/null
+++ b/dev-python/podman/podman-4.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=podman-py-${PV}
+DESCRIPTION="A library to interact with a Podman server"
+HOMEPAGE="
+ https://github.com/containers/podman-py/
+ https://pypi.org/project/podman/
+"
+SRC_URI="
+ https://github.com/containers/podman-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
+ )
+
+ # integration tests require a workable podman server,
+ # and it doesn't seem to work in ebuild env
+ epytest podman/tests/unit
+}