summaryrefslogtreecommitdiff
path: root/dev-python/podman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-24 14:55:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-24 14:55:44 +0100
commitb83b16e0f6c963583f6323fe1bb12ecbd11d6f81 (patch)
treed67748047921162af2742c3e1255e3f1421f769b /dev-python/podman
parent76617568771869151cb2a3f71939719c15dd47a2 (diff)
gentoo auto-resync : 24:07:2023 - 14:55:44
Diffstat (limited to 'dev-python/podman')
-rw-r--r--dev-python/podman/Manifest2
-rw-r--r--dev-python/podman/podman-4.4.0.ebuild52
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/podman/Manifest b/dev-python/podman/Manifest
index 0ee55ef2dd1b..2c6bec55579c 100644
--- a/dev-python/podman/Manifest
+++ b/dev-python/podman/Manifest
@@ -1,5 +1,3 @@
-DIST podman-py-4.4.0.gh.tar.gz 177587 BLAKE2B 92d2a45a20304be648247fe8c95ab7ed84795e419d79fc731a6be4f228851b10324546b9cd14f9235a3972fd9258d50b2512216121c0fef59c0eb66d7c12c91c SHA512 47b4157fd9e6d54171f6f970012e828f877c66c4fabe4f30ad93974945b9e35fa7084c2908efca42c8b71a8d9f25e7a29a624152ce7bea1eebafcaa3700cb967
DIST podman-py-4.5.0.gh.tar.gz 179025 BLAKE2B 6725bd79a5fb0a17a75080b323cf62b56a3ef83d20c7113364785e0994a053455a08d9ffb2bbbbfb646fb730367de9bfd838c7eb92053a93a55008c59ec59732 SHA512 903466e11afebd26da65cc363ab49a56255731ea8bc07d202dd80907e1dd6704b5a8542c5a417f3c46ec93882bb21ef6990ae80fe558dfd3310b9272590cbd39
-EBUILD podman-4.4.0.ebuild 1136 BLAKE2B 95a4e548de829cc240f8b20d404b8c49d55e5ecad211933e4c42984a900b84bdde719d4fb9e99314ab27b0c5da6cf79f8a95d43332be892f2320891049adaab7 SHA512 221edd3805d5cfb184d391ed1daa1880ae5cefa93aef5e761fef52b5c766868a006a2c4303bfbc156ceb9951eb25d0074f6f2dc72f5bdb7de377e9d8da5f9d2d
EBUILD podman-4.5.0.ebuild 1136 BLAKE2B 95a4e548de829cc240f8b20d404b8c49d55e5ecad211933e4c42984a900b84bdde719d4fb9e99314ab27b0c5da6cf79f8a95d43332be892f2320891049adaab7 SHA512 221edd3805d5cfb184d391ed1daa1880ae5cefa93aef5e761fef52b5c766868a006a2c4303bfbc156ceb9951eb25d0074f6f2dc72f5bdb7de377e9d8da5f9d2d
MISC metadata.xml 475 BLAKE2B 42fc2c044df94ebf8a4eb5088a39ad3075089cd5a007473db0964df4efb8c7a437c94db9c161d6ba81d2c017377919861f17b7fe3e133aa597312cad2df012f4 SHA512 017f54ebf56fc59c14ff0e9c2f15b899556ff3d512d22ed2abc35227c079ec64c8eb855f60e65299abd7f8b5433b2268dc7c2e428476efc334e24f0d90181bc8
diff --git a/dev-python/podman/podman-4.4.0.ebuild b/dev-python/podman/podman-4.4.0.ebuild
deleted file mode 100644
index 843534a57bf8..000000000000
--- a/dev-python/podman/podman-4.4.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-MY_P=podman-py-${PV}
-DESCRIPTION="A library to interact with a Podman server"
-HOMEPAGE="
- https://github.com/containers/podman-py/
- https://pypi.org/project/podman/
-"
-SRC_URI="
- https://github.com/containers/podman-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
- >=dev-python/requests-2.24[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.26.5[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-BDEPEND="
- test? (
- dev-python/requests-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
- )
-
- # integration tests require a workable podman server,
- # and it doesn't seem to work in ebuild env
- epytest podman/tests/unit
-}