summaryrefslogtreecommitdiff
path: root/dev-python/poetry-plugin-export/poetry-plugin-export-1.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-20 13:00:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-20 13:00:15 +0000
commite937ca8df21d3186f65edc11c872706c80eb8a61 (patch)
tree6758813cd0a8bd1da09045a9171ff389b1b39718 /dev-python/poetry-plugin-export/poetry-plugin-export-1.7.1.ebuild
parent1b5d79237a144dcb8753c783941843d879a906e2 (diff)
gentoo auto-resync : 20:03:2024 - 13:00:14
Diffstat (limited to 'dev-python/poetry-plugin-export/poetry-plugin-export-1.7.1.ebuild')
-rw-r--r--dev-python/poetry-plugin-export/poetry-plugin-export-1.7.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/poetry-plugin-export/poetry-plugin-export-1.7.1.ebuild b/dev-python/poetry-plugin-export/poetry-plugin-export-1.7.1.ebuild
new file mode 100644
index 000000000000..a1e7b242c958
--- /dev/null
+++ b/dev-python/poetry-plugin-export/poetry-plugin-export-1.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A plugin that allows the export of locked packages to various formats"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry-plugin-export
+ https://pypi.org/project/poetry-plugin-export/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-1.8.0[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ test? (
+ dev-python/poetry[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-3.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest