summaryrefslogtreecommitdiff
path: root/dev-python/poetry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-17 00:13:57 +0000
commit27b3683509c5229cce540418778a8b64afbc0009 (patch)
treeb7164898142b8b093b91c8254c4387b6eec679ee /dev-python/poetry
parentf2bdc27fe0f79f8f9a3945eb2b1163ce75c56439 (diff)
gentoo auto-resync : 17:02:2025 - 00:13:57
Diffstat (limited to 'dev-python/poetry')
-rw-r--r--dev-python/poetry/Manifest2
-rw-r--r--dev-python/poetry/poetry-2.1.0.ebuild86
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/poetry/Manifest b/dev-python/poetry/Manifest
index 2814135fee22..cb93886df630 100644
--- a/dev-python/poetry/Manifest
+++ b/dev-python/poetry/Manifest
@@ -1,3 +1,5 @@
DIST poetry-2.0.1.tar.gz 2846041 BLAKE2B 691ffcd39799d0794f8853cdb9742d95d5dd64a62488af56f58b6ac1d8b7e734b109375d595f975e7b310bd3c36a5b5c846dd37e2ffd7bf2fe7d25bd1835cff1 SHA512 9a53fe5cbaea7c923e8af6920b545a54402d49937f31c5812dcc8939f8db44ea2557302f54e015fd7f7e96de66d8fc90596cd06a30dc53ef474a8bb54fdc2c97
+DIST poetry-2.1.0.tar.gz 3433096 BLAKE2B 27feceb8c5bced84f508a538da231749f18724fd92051f328dbe9cc103c1988773a04e5526c5117c499df5a3121228d50dedb0d12f3a90f0d89b4438ae61245e SHA512 09757d3ca668e014d1591cb56a54013f34eec3b3d4216a2408ae73c2b784a2798727bfd65fb35cf604423cf0d67f2cfcff8f709d14debc9623d1dc9a863f4e68
EBUILD poetry-2.0.1-r1.ebuild 2541 BLAKE2B 0a051be10c58887428a65ea67620812f3f4123ee82fcb5c7d7b0d3dbab23fa5509f2cc8bdea3de9dbec6c255ef7aec6f96eb754d17b7f63f9c44946e91ab6ff8 SHA512 fdc3629bca97ca4eca17b832a4794bcc0cb630c92431cf5b6ea0389b07d12250925b6d3292ac39d3e9d1ae004b02b3805aa7e3ebb8143079d248ad0696d208ae
+EBUILD poetry-2.1.0.ebuild 2803 BLAKE2B c894ec787c95480ef416d6eaf5f95287e2cd0a88cd41212d9319085b76f71f7ae1d1c8792ae35e5f05104c63beb62e9c98a152b6f1187e4c9c3680cb73ba3a1d SHA512 0406d333ee9b971f7f0112a2eb935d112f1c1e9b5955a2cd3b48844281b61501fd586b757fd26588a5e8d6d8b0675e784b047deb28489ea7ee8881bf533bccfc
MISC metadata.xml 486 BLAKE2B 7757afe2f964f49a04a600ec80af8511387c3a80105c9050755e1815cac148734f540e4da8c1da401c15a63bf5d0a8200ed6a5e1c09e5dacc7d39f5f59dd343f SHA512 541063e55b4dc5b927ef4ff6b385663bbf978d13ac6644c2537483ec42f211780cab4d881b159894dfe86519b4655c80bcfe17cdb90a2e033077b390a3842f46
diff --git a/dev-python/poetry/poetry-2.1.0.ebuild b/dev-python/poetry/poetry-2.1.0.ebuild
new file mode 100644
index 000000000000..8af87f6b1849
--- /dev/null
+++ b/dev-python/poetry/poetry-2.1.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A frontend for poetry - a python dependency management and packaging tool"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry
+ https://pypi.org/project/poetry/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/poetry-plugin-export-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/build-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/cachecontrol-0.14.0[${PYTHON_USEDEP}]
+ >=dev-python/cleo-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.22.6[${PYTHON_USEDEP}]
+ >=dev-python/fastjsonschema-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/findpython-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/installer-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/keyring-25.1.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-24.0[${PYTHON_USEDEP}]
+ >=dev-python/pbs-installer-2025.01.06[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.12[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/shellingham-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+ >=dev-python/trove-classifiers-2022.5.19[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.26.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/deepdiff-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-1.1[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-classes-3.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # unpin
+ sed -e 's:,<[0-9.]*::' -e 's:==\([0-9]\):>=\1:' -i pyproject.toml || die
+
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Internal test for lockfile being up-to-date
+ # Meaningless, also sdist does not include lockfile
+ tests/installation/test_installer.py::test_not_fresh_lock
+
+ # broken if poetry-plugin-export is installed
+ 'tests/console/test_application_command_not_found.py::test_application_command_not_found_messages[x-None]'
+
+ # TODO
+ tests/installation/test_executor.py::test_executor_known_hashes
+ tests/puzzle/test_provider.py::test_search_for_directory_setup_read_setup_with_no_dependencies
+ tests/utils/env/test_env_manager.py::test_create_venv_finds_no_python_executable
+ tests/utils/test_python_manager.py::test_python_get_preferred_default
+ 'tests/inspection/test_info.py::test_info_setup_missing_mandatory_should_trigger_pep517[name]'
+)
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network" -p pytest_mock
+}