summaryrefslogtreecommitdiff
path: root/dev-python/poetry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-13 06:41:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-13 06:41:32 +0000
commit4b1d73e089a436406c89fadc33638314981c44e6 (patch)
tree1777930320566e090b2b462273c045e555b85b86 /dev-python/poetry
parentdc9bfd846ffa3990be92029481684342bc57218e (diff)
gentoo auto-resync : 13:01:2025 - 06:41:32
Diffstat (limited to 'dev-python/poetry')
-rw-r--r--dev-python/poetry/Manifest2
-rw-r--r--dev-python/poetry/poetry-2.0.1-r1.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/poetry/Manifest b/dev-python/poetry/Manifest
index e74d5437b52b..3f8c06633677 100644
--- a/dev-python/poetry/Manifest
+++ b/dev-python/poetry/Manifest
@@ -1,5 +1,7 @@
DIST poetry-1.8.5.tar.gz 1519790 BLAKE2B 378cb327fe6762e8dd09d7f08fb11cd17963c382754a20fba3cc000ac07ab93672b54d967ba6d609d00e9f303461e55ec40eb9549a0b9329f50c4af363fd2343 SHA512 91c2902e5dfb8f3319de53472b1da20b1d8f570a7a3212e6e55883e364295a9e58ce5b7c59450e741f97692e897283d9f624f3d2128db017476d94fd2ea7839c
DIST poetry-2.0.0.tar.gz 2844621 BLAKE2B 17c3c91c839e3a7bd5f27b7659cd4906bfc5337d64699d92614bd880f1c9351ab2dd05d8486ce7304860b1705c0f6e16526f10e2f7f71ec2ad5234807fca3327 SHA512 82ecf902dfa804ff54f4d77557d51d781f29a532699d3d901a844c9ed5906d421869d90789468d563febaa838ad6b237c0021eb4b27953233e351929ca556c1d
+DIST poetry-2.0.1.tar.gz 2846041 BLAKE2B 691ffcd39799d0794f8853cdb9742d95d5dd64a62488af56f58b6ac1d8b7e734b109375d595f975e7b310bd3c36a5b5c846dd37e2ffd7bf2fe7d25bd1835cff1 SHA512 9a53fe5cbaea7c923e8af6920b545a54402d49937f31c5812dcc8939f8db44ea2557302f54e015fd7f7e96de66d8fc90596cd06a30dc53ef474a8bb54fdc2c97
EBUILD poetry-1.8.5-r1.ebuild 2438 BLAKE2B 92099ff2e6a63d9bbf1e19902e2bc788ccd8ae8b5ce1ad06eb9179b7be503d507fc55c13164b663032f334762a44773e0328cac03f8ada9bac15b4687c181c64 SHA512 c5c66eb6bcdb12223629e6949fd961313849ba9d004b09bd07017c4d1cb04584ed81783afd70c5bd97ae8e8e28c8fe1d16a3fe44ed78dde4c7134bd53840f4c3
EBUILD poetry-2.0.0.ebuild 2616 BLAKE2B 618ce4522f6be32c739d513c8a7c8ebf764f59e62bcc6582998b459ad194158876d6c49b417b455bd1e2ccab293872d2c746c195ded2d89ef4c945c61ed0a54e SHA512 fd962e6929ea0442685bc5698a5893236d6a8bbbcb6f16820c592532b662b25c13792acd87e9277ccf10ddc1fbdacdd66b8aabd42725899b0eb4c677c2d841b9
+EBUILD poetry-2.0.1-r1.ebuild 2541 BLAKE2B 0a051be10c58887428a65ea67620812f3f4123ee82fcb5c7d7b0d3dbab23fa5509f2cc8bdea3de9dbec6c255ef7aec6f96eb754d17b7f63f9c44946e91ab6ff8 SHA512 fdc3629bca97ca4eca17b832a4794bcc0cb630c92431cf5b6ea0389b07d12250925b6d3292ac39d3e9d1ae004b02b3805aa7e3ebb8143079d248ad0696d208ae
MISC metadata.xml 486 BLAKE2B 7757afe2f964f49a04a600ec80af8511387c3a80105c9050755e1815cac148734f540e4da8c1da401c15a63bf5d0a8200ed6a5e1c09e5dacc7d39f5f59dd343f SHA512 541063e55b4dc5b927ef4ff6b385663bbf978d13ac6644c2537483ec42f211780cab4d881b159894dfe86519b4655c80bcfe17cdb90a2e033077b390a3842f46
diff --git a/dev-python/poetry/poetry-2.0.1-r1.ebuild b/dev-python/poetry/poetry-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..3de893c32002
--- /dev/null
+++ b/dev-python/poetry/poetry-2.0.1-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A frontend for poetry - a python dependency management and packaging tool"
+HOMEPAGE="
+ https://python-poetry.org/
+ https://github.com/python-poetry/poetry
+ https://pypi.org/project/poetry/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/poetry-core-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/poetry-plugin-export-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/build-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/cachecontrol-0.14.0[${PYTHON_USEDEP}]
+ >=dev-python/cleo-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.22.6[${PYTHON_USEDEP}]
+ >=dev-python/fastjsonschema-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/installer-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/keyring-25.1.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-24.0[${PYTHON_USEDEP}]
+ >=dev-python/pkginfo-1.12[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/shellingham-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+ >=dev-python/trove-classifiers-2022.5.19[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.26.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/deepdiff-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-1.1[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-classes-3.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.9[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # unpin
+ sed -e 's:,<[0-9.]*::' -e 's:==\([0-9]\):>=\1:' -i pyproject.toml || die
+
+ distutils-r1_src_prepare
+}
+
+EPYTEST_DESELECT=(
+ # Internal test for lockfile being up-to-date
+ # Meaningless, also sdist does not include lockfile
+ tests/installation/test_installer.py::test_not_fresh_lock
+
+ # TODO
+ tests/installation/test_executor.py::test_executor_known_hashes
+ tests/puzzle/test_provider.py::test_search_for_directory_setup_read_setup_with_no_dependencies
+ tests/utils/env/test_env_manager.py::test_create_venv_finds_no_python_executable
+ tests/utils/test_python_manager.py::test_python_get_preferred_default
+ 'tests/inspection/test_info.py::test_info_setup_missing_mandatory_should_trigger_pep517[name]'
+)
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network" -p pytest_mock
+}