summaryrefslogtreecommitdiff
path: root/dev-python/polib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /dev-python/polib
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'dev-python/polib')
-rw-r--r--dev-python/polib/Manifest1
-rw-r--r--dev-python/polib/polib-1.1.0-r1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/polib/Manifest b/dev-python/polib/Manifest
index ae72fbec302c..c354764a939c 100644
--- a/dev-python/polib/Manifest
+++ b/dev-python/polib/Manifest
@@ -2,5 +2,6 @@ AUX polib-1.0.7-BE-test.patch 545 BLAKE2B 800372796d19d98f47dff73ed593dcbe8a60d5
DIST polib-1.0.7.tar.gz 156282 BLAKE2B 4d4a9f9901fe7b7b7aa5fc54b9391e051b8d02d1749752e1c9a563d9285670db5d43d7c5015fe266f78c89d1ff7a334bd2afe2d7d8b68fb376df35f8902cb0ed SHA512 bfec3538f9ab499ff2149bb40e0685b4cb6d5f0bc7ce8dc33e1fc511a6169e01c1a317e652daed7b3bfd9bbfe6ee1d545b4d8913f54e91504c4debb5b1b94b6e
DIST polib-1.1.0.tar.gz 158484 BLAKE2B 41766f00e3928eacf3c98406b6acce224f0d0cb44d79326c834db900ed8b91181911ab7e26845a737057dd07c067a784d0b06278952708c17888db42d8c1e303 SHA512 74681585b4d7252e107acd7d73f49f7e91c90adcd180722d39d35c40ec158434798af0124a16788cf564c73b84f52a040aefeb58355a1a3cd85848c3f6a5e67f
EBUILD polib-1.0.7.ebuild 842 BLAKE2B 90516dc6a38bafe56cb80a778f8e352cead7af9039c65951ab2d0c4a1d909a08444ce1ac64c23e8e409a15f2e04aba4e26542512498ad30fa15e874c3a05febf SHA512 4d21d499a37b41ae378432b2954a238ef73cd163fe71472534521bc1b303dc0bf3269da2cb9b151f929a1f9dd7e563df5d8fb6bb0a210a6c75350ec58f80bba0
+EBUILD polib-1.1.0-r1.ebuild 859 BLAKE2B f78d819212e1643f5588bb3c0326061046ca448286fd03cd5bd1e119dd67434c51285eecda3715f78bed961df220949880440ea500fdd40ad17674012c1b4e29 SHA512 57ccd7e5ff75462ad47d2849f6c8b355508ba9742b0ba84aa96789f5dafa2830af386671b5ee3f6015b9ff5cd3b457b68b870e28d9bafbb3925ee04eb350c19a
EBUILD polib-1.1.0.ebuild 857 BLAKE2B c47a55c248b5989065f58790204368a894249c9fc9db31053e49740a4108e9fb067f20e54ce9a8b02192968ca952021c83c5b3dbc7df2b1dd184302ed06884cb SHA512 4e80bb72788255b426b62b684289b75e9c09e3215913bf0ce188b65f3beaa7d27c002f2a9dfb4b0f2049a50c394cccebe42086d3872189c3ec95a9beced485df
MISC metadata.xml 294 BLAKE2B 096af7abe45b2be00baf31d9a8eb7f9606c817c48e08fb457961b48c533b6c35c5acdba95420d7a193c5a216f3d46aa512ea54e0a2ff45f9173e76720689b99f SHA512 f5fe76b50e225e8e3f3e4d745c7e49b0056eac52b46c0a51cd552ffffbf915b5035d5edc2428c15e6497a054bd475eff39ea19a5c3e79eb2f087ee8ee0565099
diff --git a/dev-python/polib/polib-1.1.0-r1.ebuild b/dev-python/polib/polib-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..6873694edef0
--- /dev/null
+++ b/dev-python/polib/polib-1.1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library to manipulate gettext files (.po and .mo files)"
+HOMEPAGE="https://bitbucket.org/izi/polib/wiki/Home"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.7-BE-test.patch
+)
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" tests/tests.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}