summaryrefslogtreecommitdiff
path: root/dev-python/polygon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/polygon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/polygon')
-rw-r--r--dev-python/polygon/Manifest5
-rw-r--r--dev-python/polygon/metadata.xml13
-rw-r--r--dev-python/polygon/polygon-2.0.6.ebuild25
-rw-r--r--dev-python/polygon/polygon-3.0.7.ebuild39
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/polygon/Manifest b/dev-python/polygon/Manifest
new file mode 100644
index 000000000000..af22a77ebd83
--- /dev/null
+++ b/dev-python/polygon/Manifest
@@ -0,0 +1,5 @@
+DIST Polygon2-2.0.6.zip 73551 BLAKE2B 0ce0359945f87f0efcd9fd61a2538dec96a76265d3b4d13a53288609e6bfde45c946f9184ee6268a24f987c5081ca10d8261d7febcbaee218f10f9fa8b2a3875 SHA512 d0827fe3299449842e201598b59e423bf3029302037ffb9329dae0045b2be1727eb33951dfd22f560476360836305526be58e55d9d4cff36f3d9a4b0262b7aed
+DIST Polygon3-3.0.7.zip 76193 BLAKE2B 57ef62b6652400be057e8596f705e2112caef09208aafa7e46686f86367181dc078cbfc6ade99af22cce7fc0a76ec1de2995885ba4c11263444ca315029c38d7 SHA512 e30cd8e51ad69a2d76b61a7d92ead4ac352e729093546b965f649866fd9c6a860e3cdcd9fcd7f8cc9f8d7735ccd1128fb5af00b3de89e4efd7128e446a70b33b
+EBUILD polygon-2.0.6.ebuild 568 BLAKE2B 98141dc77592acb522fb80f74ab96317bb84e3daade4372f46e1a60ad65064dd49125e3a17ab028ad163bac324c680e30c5bee61db71672864aa04d0d1170235 SHA512 52130f04ac0e59b14469643f104d732ac4b4e8060aba7079666d0f760e2ebb59fba00e092c18b612bb0e1f2b352b6f507aa88067d30447483da08e8d13db984d
+EBUILD polygon-3.0.7.ebuild 881 BLAKE2B 672dc4f77c8b3237b757fa3a1ff5ad3c423c39b74b7a01e7f67c5b90d4203bfa82eea511386f1d0c1efe33cf0d602e06146840394b6078b398f537a304c02094 SHA512 9f20ec703b782f8e7ecfe23f364a204145e896b1baa3ad52faa36ccdc008ea1bc85549113e474e0428d55154623c793cd509551b64f3dcc7f192999320c7ca6c
+MISC metadata.xml 498 BLAKE2B 37a852bfcd8d3b2cb147e45532ff82192c14c415a4cc86671e1ce1b26dd1154778e907421ab7bcd61d602cfd8864dad6bed1ade6e07f4f9257bea072f7623d1c SHA512 f720cc8215dab75ac6246e86d3ee3fe6a07676078a25848924fc0ced02826bb8b2122417d5b27549f9557b486a4e71baff27bc7d54d7f8d15d7a21b4caa0de52
diff --git a/dev-python/polygon/metadata.xml b/dev-python/polygon/metadata.xml
new file mode 100644
index 000000000000..9bc334c95381
--- /dev/null
+++ b/dev-python/polygon/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Polygon is a python package that handles polygonal shapes in 2D. It contains
+ Python bindings for gpc, the General Polygon Clipping Library by
+ Alan Murta and some extensions written in C and pure Python.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/polygon/polygon-2.0.6.ebuild b/dev-python/polygon/polygon-2.0.6.ebuild
new file mode 100644
index 000000000000..c411417e96cf
--- /dev/null
+++ b/dev-python/polygon/polygon-2.0.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to handle polygonal shapes in 2D"
+HOMEPAGE="https://www.j-raedler.de/projects/polygon/"
+SRC_URI="https://www.bitbucket.org/jraedler/${PN}2/downloads/Polygon2-${PV}.zip"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/Polygon2-${PV}
+
+DOCS=( HISTORY doc/Polygon.txt )
+
+python_test() {
+ ${PYTHON} test/Test.py || die "Tests failed"
+}
diff --git a/dev-python/polygon/polygon-3.0.7.ebuild b/dev-python/polygon/polygon-3.0.7.ebuild
new file mode 100644
index 000000000000..4932e85b87cc
--- /dev/null
+++ b/dev-python/polygon/polygon-3.0.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to handle polygonal shapes in 2D"
+HOMEPAGE="https://www.j-raedler.de/projects/polygon/"
+SRC_URI="https://www.bitbucket.org/jraedler/${PN}3/downloads/Polygon3-${PV}.zip"
+
+LICENSE="LGPL-2"
+SLOT="3"
+IUSE="examples"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/Polygon3-${PV}
+
+DOCS=( doc/{Polygon.txt,Polygon.pdf} )
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples || die
+ mv doc/{Examples.py,testpoly.gpf} examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} test/Test.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}