summaryrefslogtreecommitdiff
path: root/dev-python/polygon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/polygon
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/polygon')
-rw-r--r--dev-python/polygon/Manifest1
-rw-r--r--dev-python/polygon/polygon-3.0.7-r1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/polygon/Manifest b/dev-python/polygon/Manifest
index 6dc0d22f1ffd..8eea44e5f34f 100644
--- a/dev-python/polygon/Manifest
+++ b/dev-python/polygon/Manifest
@@ -1,3 +1,4 @@
DIST Polygon3-3.0.7.zip 76193 BLAKE2B 57ef62b6652400be057e8596f705e2112caef09208aafa7e46686f86367181dc078cbfc6ade99af22cce7fc0a76ec1de2995885ba4c11263444ca315029c38d7 SHA512 e30cd8e51ad69a2d76b61a7d92ead4ac352e729093546b965f649866fd9c6a860e3cdcd9fcd7f8cc9f8d7735ccd1128fb5af00b3de89e4efd7128e446a70b33b
+EBUILD polygon-3.0.7-r1.ebuild 969 BLAKE2B 6a5d46a717d84a6d43c3e35773ffecb6d7b2793bf335f45cffa9e99a161303579259e0645a079be58ae5d95ba8ef552a285fbe15254cc43a8669b5d8b9f8fd22 SHA512 292c41ccf0abd0fc55ae33f16b65124eabfd92cb988add1febe06785ed86e86b6d8fb6fbcc385278a5f43016dec61f070222a113b0b7a3e030042221004dde24
EBUILD polygon-3.0.7.ebuild 963 BLAKE2B 859e85a0966c94b227260cc4b805e904196a664d20ba2605db959dec7d6b38e34dbf3c83a24a488524b93a1f05efc2300dc80f9f19b1b4454dce72ecbe146cea SHA512 314d2e08c05d162a9ddfcd525e2fb7d1c6c755698e43a5dce14f2ca49b9e7398ce6a6b64bc720a5ba6da6824f8aa74abe357c9fc738c3a993b9f59ff2a48ccf8
MISC metadata.xml 569 BLAKE2B 1fad2b421470fb4865d91c2afc1d0ce0f3cad77a422cf536d117724de6b4f737df33550ebe4776612dd3df36ee27639e761c7bebf12dc365d85afafbc5a9c379 SHA512 fa598556eeeac052822eb3cd6cdfa9c24bc9bd27c12ed2ce4f70a234bc0d8957303a2cbf1980a50d9a781177d0c462e7232e8b77baed815918bb8594c65f4101
diff --git a/dev-python/polygon/polygon-3.0.7-r1.ebuild b/dev-python/polygon/polygon-3.0.7-r1.ebuild
new file mode 100644
index 000000000000..abdaae630441
--- /dev/null
+++ b/dev-python/polygon/polygon-3.0.7-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to handle polygonal shapes in 2D"
+HOMEPAGE="https://www.j-raedler.de/projects/polygon/"
+SRC_URI="https://www.bitbucket.org/jraedler/${PN}3/downloads/Polygon3-${PV}.zip"
+S="${WORKDIR}/Polygon3-${PV}"
+
+LICENSE="LGPL-2"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+BDEPEND="app-arch/unzip"
+
+DOCS=( doc/{Polygon.txt,Polygon.pdf} )
+
+python_prepare_all() {
+ if use examples; then
+ mkdir examples || die
+ mv doc/{Examples.py,testpoly.gpf} examples || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" test/Test.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}