summaryrefslogtreecommitdiff
path: root/dev-python/pooch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-05 12:08:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-05 12:08:58 +0000
commitf29a41111b3a606f5d95049b1ba92daabbc68cc0 (patch)
tree310589df1ffb427b1a0595a329cfb2845335b778 /dev-python/pooch
parent083bdfbef9bc532b72cf116591025916eebaf676 (diff)
gentoo auto-resync : 05:01:2023 - 12:08:57
Diffstat (limited to 'dev-python/pooch')
-rw-r--r--dev-python/pooch/Manifest2
-rw-r--r--dev-python/pooch/pooch-1.6.0.ebuild24
2 files changed, 20 insertions, 6 deletions
diff --git a/dev-python/pooch/Manifest b/dev-python/pooch/Manifest
index c4f870600657..a74cd82ad3c7 100644
--- a/dev-python/pooch/Manifest
+++ b/dev-python/pooch/Manifest
@@ -1,3 +1,3 @@
DIST pooch-1.6.0.tar.gz 52318 BLAKE2B c5cdf04a27a5754accee5a4522d5e6a51c4e71b7034cd570c6a2f30bc580ba9c15e0717be792e7cdd020ca745e6813a63681ce966ad61c0ed4aaa8b84829b920 SHA512 e1b6253b8879ef172bd6370139a7807355c7e1c03a1626ac46cb083b1f7d8beb5a8adb08c0828eb34e96a7164211d2dc7da214fd0176eb0606fe4ff47911257c
-EBUILD pooch-1.6.0.ebuild 945 BLAKE2B 6cae26a824d81cae6d0c260938115b409fa5f1cf66beb4f9bb4fbb48b6a3f478967bfb31ccabd40487a4e2589007f33adc587f717570361bd167a2a3cab89351 SHA512 b48468199592c442cc0055af257ce0fbb2acc12f5ac13863b862e6fd1f166ca6206f80799f9ed2c749ec8e981fd0c923bf341f017cda4c0300df124e35e1e989
+EBUILD pooch-1.6.0.ebuild 1457 BLAKE2B 1c7a06fe7650e8165145d7e84c57b55a3fc9223fae7e3c272006115ba8da9a72f6abad6b0de419053078907735dfe8409543aef99da084ef8f7ca7a22339cc32 SHA512 1092d9c8e75633e923116a39267c7b0093171605e35601ba89672d6f0690a3231108d0fd5271ad833eebc629fe6bc9644164cf3db801920b2e4b608c199f9b93
MISC metadata.xml 684 BLAKE2B b6cd1db5a31f316800c9c5e15e11c858bebc81b7c38ced227e7f54a5a0386462fa9a92bb8f177d9df0d3fea00775dced1e2eebbb1622fededdac87ce40db21e7 SHA512 a96adfa4b8996e2685f7d5ea8ab6936fcc795a3f517da8ec14e885c08b2ae1f6d950ea9314e8aa6a4b2a4b436a23d1e98a6d56b5ae0c633bffc4fbeaca4058a4
diff --git a/dev-python/pooch/pooch-1.6.0.ebuild b/dev-python/pooch/pooch-1.6.0.ebuild
index 6c6de3de6478..76419d5266a5 100644
--- a/dev-python/pooch/pooch-1.6.0.ebuild
+++ b/dev-python/pooch/pooch-1.6.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -14,8 +14,6 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-RESTRICT="test"
-PROPERTIES="test_network"
RDEPEND="
dev-python/appdirs[${PYTHON_USEDEP}]
@@ -28,7 +26,19 @@ BDEPEND="
dev-python/paramiko[${PYTHON_USEDEP}]
dev-python/pytest-localftpserver[${PYTHON_USEDEP}]
dev-python/tqdm[${PYTHON_USEDEP}]
- )"
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Needs network
+ "pooch/tests/test_core.py::test_check_availability_on_ftp"
+ "pooch/tests/test_downloaders.py::test_invalid_doi_repository"
+ "pooch/tests/test_downloaders.py::test_doi_url_not_found"
+ "pooch/tests/test_downloaders.py::test_figshare_url_file_not_found[figshare]"
+ "pooch/tests/test_downloaders.py::test_figshare_url_file_not_found[zenodo]"
+ "pooch/tests/test_downloaders.py::test_doi_downloader[figshare]"
+ "pooch/tests/test_downloaders.py::test_doi_downloader[zenodo]"
+)
### docs no included in pypi tarball
# distutils_enable_sphinx doc \
@@ -36,3 +46,7 @@ BDEPEND="
distutils_enable_tests pytest
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ epytest -k "not network"
+}