summaryrefslogtreecommitdiff
path: root/dev-python/pp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pp')
-rw-r--r--dev-python/pp/Manifest3
-rw-r--r--dev-python/pp/metadata.xml13
-rw-r--r--dev-python/pp/pp-1.6.5.ebuild28
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pp/Manifest b/dev-python/pp/Manifest
new file mode 100644
index 000000000000..887c1573f1d2
--- /dev/null
+++ b/dev-python/pp/Manifest
@@ -0,0 +1,3 @@
+DIST pp-1.6.5.tar.bz2 27185 BLAKE2B 3148b9d9c251a8f75348f4a5b4905d658054b44ef959b4e9617532f69d6d0c12379c68c86cb91a8151de50b9434844ee6746cc266e253a4417228895178c3aec SHA512 b72c3e12b770f386b213a0325748a7e99d225a608a5453929004b06aaaa8fb69b40054a3bcb1d8b30a640f7db7a945b0ae8c1b1a1d753855668553d18a18bbfe
+EBUILD pp-1.6.5.ebuild 617 BLAKE2B c9cda62671a799b6db808ec5abe2fedce19e7a180365eff6193a508fd2ee94245370a1087c6fd9dfbacdca9ec72141960df51c7ea07e1bc2b7888a8caee2a1cf SHA512 c0b9e70c30df277550db1db85b53a5d02f4412f42f15c43471aa351ee4130ea6f2b26931b965b41e3af5fdcc9936103b35166522251728488e977ae71393a63a
+MISC metadata.xml 485 BLAKE2B b45925828641bb14a94fc2aef987654643219b4a58d57a1551b675bb10700d077a69d8cb8783a92aa8273971476ed22eb9b9216ea4e29d28a8fcddcffa9aa1ae SHA512 68f07655eb89478f3fd4bd5f2312706ae48ffb23ae5da7c120dbcfed34fb3476bd9aa8b82de033db604bf04a8056b7765d46b83b72c5df4187dbd1d37a907a51
diff --git a/dev-python/pp/metadata.xml b/dev-python/pp/metadata.xml
new file mode 100644
index 000000000000..3569a6dd52bf
--- /dev/null
+++ b/dev-python/pp/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ PP is a python module which provides mechanism for parallel
+ execution of python code on SMP (systems with multiple processors or
+ cores) and clusters (computers connected via network).
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pp/pp-1.6.5.ebuild b/dev-python/pp/pp-1.6.5.ebuild
new file mode 100644
index 000000000000..467a8f15bfab
--- /dev/null
+++ b/dev-python/pp/pp-1.6.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Parallel and distributed programming for Python"
+HOMEPAGE="https://www.parallelpython.com/"
+SRC_URI="https://www.parallelpython.com/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+python_install_all() {
+ doman doc/ppserver.1
+ use doc && HTML_DOCS=( doc/ppdoc.html )
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r "${S}/examples"
+ fi
+ distutils-r1_python_install_all
+}