summaryrefslogtreecommitdiff
path: root/dev-python/pretty-yaml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pretty-yaml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pretty-yaml')
-rw-r--r--dev-python/pretty-yaml/Manifest5
-rw-r--r--dev-python/pretty-yaml/metadata.xml13
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-15.6.3.ebuild29
-rw-r--r--dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild32
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/pretty-yaml/Manifest b/dev-python/pretty-yaml/Manifest
new file mode 100644
index 000000000000..d79f33c2b125
--- /dev/null
+++ b/dev-python/pretty-yaml/Manifest
@@ -0,0 +1,5 @@
+DIST pyaml-15.6.3.tar.gz 14459 BLAKE2B 3329d47f5cfc3de1a2916ac2f7cbe6bb0ac0739fe7704a4a3c684d9a050f9272c16140cf3fe040fe74b86f71e46ac626fe179bec04fbeccf6962ae959b846953 SHA512 9d0789342f59adfc415bef54cdc52b75cbcf1fa71940e1b9534ea0c141c5737449104e45fb0feea968e58d0886a74d9a5bbec0ba05b7d72cf5d93d3a674b5868
+DIST pyaml-15.8.2.tar.gz 16544 BLAKE2B 1e9820c172bb0c2e05c78f5dee3299c6bb0d83e2c658f3cd45322abac3404af1c9dd1f3b00e2c7b285cbd00c17d382c82cbb16b96bbac10021a0ca1a008d0287 SHA512 74f1fdacdd601f0b6f710457627e4dcbc42e7301fe5faa061d3e8d593842d6e5dd85041625aba576bba9cda2a713ee07ca3067221a720cbddc6dcd417fccee64
+EBUILD pretty-yaml-15.6.3.ebuild 742 BLAKE2B 048510603225c8cd10a58a9abfd808928b4da56276fc598bd3cf142c327a44efe433400065fa309658ff9505be937d7f360e5d614295217720a2c8676f5eee36 SHA512 8dd9b33127109b69e409eda665707a7a78a79ab03a0fdbcbd9ea18c976441102ad4c41a0d0a854db74409d9df305f10808c014eec1c7893766c8bfa0d2d9575e
+EBUILD pretty-yaml-15.8.2.ebuild 760 BLAKE2B 3fff66869f33504b79c5c5d2b6f6b65ceb0b6927bc48f83a22d19ef81827d0fe058f42534b49e9c7c0246e05ee61003a4208783f1adec2f3b3e17234e3cfab8f SHA512 e3838a02f71c88854ac986c47f7e0f6ce55ebbeb844fcc31d2abdbd6e55e80ff614d6f13c58e34dbdd136398db16f6e348383cfbfdd07aea72c567c8a1e82477
+MISC metadata.xml 444 BLAKE2B 522c0c3698f3c35b698b255504afbcda02c321e542ba7013fb0e3de4f57334b31ee014dbfdc8914dd2760a621ab1724a9142029d506d8fa44831726ae7c2b6a9 SHA512 70aee75c33eaa54fc003d6879ada0d4fc772d00619273c7b0e7c5829dcffb8ba23171c563e6e922504d9256f53ee207b36b98240bec3d084a8e6de15e0013732
diff --git a/dev-python/pretty-yaml/metadata.xml b/dev-python/pretty-yaml/metadata.xml
new file mode 100644
index 000000000000..c3f03708b939
--- /dev/null
+++ b/dev-python/pretty-yaml/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyaml</remote-id>
+ <remote-id type="github">mk-fg/pretty-yaml</remote-id>
+ <bugs-to>https://github.com/mk-fg/pretty-yaml/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pretty-yaml/pretty-yaml-15.6.3.ebuild b/dev-python/pretty-yaml/pretty-yaml-15.6.3.ebuild
new file mode 100644
index 000000000000..c926505676fb
--- /dev/null
+++ b/dev-python/pretty-yaml/pretty-yaml-15.6.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN//retty-}"
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/unidecode[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ "${PYTHON}" pyaml/tests/dump.py || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild b/dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild
new file mode 100644
index 000000000000..3b4783abbe74
--- /dev/null
+++ b/dev-python/pretty-yaml/pretty-yaml-15.8.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN//retty-}"
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ "${PYTHON}" pyaml/tests/dump.py || die "tests failed under ${EPYTHON}"
+}