summaryrefslogtreecommitdiff
path: root/dev-python/prettytable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-26 06:49:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-26 06:49:21 +0000
commit3e90fd411cb5f48da3f2487a4ea0efcbee2bfa08 (patch)
tree7c9660a764d1acdb90fea6ec5c4f6807eaebaf4c /dev-python/prettytable
parent4dec849539ecb0ceab14d66af84960f01b9a284c (diff)
gentoo auto-resync : 26:01:2025 - 06:49:21
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest2
-rw-r--r--dev-python/prettytable/prettytable-3.13.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index abb653a64588..b3164fd71cef 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,3 +1,5 @@
DIST prettytable-3.12.0.tar.gz 59539 BLAKE2B f484f90515af5306ed56fda516ac5fa6ea2b6acf5fdde9b3e6f40bd147cc19b4934819d169b1de96d6feaf1170a57556f43308f4bb82af680a7acbd2b6913642 SHA512 ccbbf2467725d1ea75b1d90468da2369f41de7cc0c15c67e27efbfee8d35bfeeba4c959752980561978d37fb603e1b7b17400b9e983876daa19456c790b492ec
+DIST prettytable-3.13.0.tar.gz 61087 BLAKE2B 6f6a64c06dd44090824cdb849c0e20bbd2a3d2ca80f243aabd732b63798a6370e64afe6ff66f4c936461ebef2329efdca9bdd6e028186856baf60e2f050e27d5 SHA512 97aa5b33491c244aa61f1042ad298e4df1effe004a6fa349d1ae1da27c4b89f7095377d214a789ba803c765ba16104acd5a6e80754a089dc5f8dc8c4d17b67fb
EBUILD prettytable-3.12.0.ebuild 860 BLAKE2B 3bdc6d40285f99b907cb6abba0f26cfbc52edf39ea3d189f7a42b5686e95e6abb70ddfe3753e90cfc930079d05c7a014b41119adf70b332a9493de326fe5cebf SHA512 872a14c117855ef93bb7c6cec00f271c78d865ecc0b31cb04415933781f634a21c6aaa0eb1495a0362ca31be3f4fc818c26b20546163bcbad6c861ad1264081e
+EBUILD prettytable-3.13.0.ebuild 865 BLAKE2B b69f25cc03e9e25b7e3c000493cc9476ed549aaa900ccabac38644961c37088fde10e3481c058f05657648b429e7a5ba44404c3d6f50dc1fdf97d5b56fb36ec4 SHA512 ac1d3bc3b54ddc95aa57c8ff62f67863c019fcecf129cd36dadcf15c883c83522275ce386b8790e8c4eea06c5ccddbbae1bb7214d66291eae388239fa8a77c06
MISC metadata.xml 528 BLAKE2B 21627ff0b6f1e48b09a0a701047720a70eb58439eb1f58ebb079bc325bea9bf1ed458010d6a171bdb6775f71d3fa5330d59c747825fe51de91d4cb68ada616c0 SHA512 4685264c305ca320d841d230179f29225862d4912fa7cfbe7151eea2d3792009716276eff1836a574fd532cffb86aac51c82a55357c02d27a361a208de649d53
diff --git a/dev-python/prettytable/prettytable-3.13.0.ebuild b/dev-python/prettytable/prettytable-3.13.0.ebuild
new file mode 100644
index 000000000000..5e1bdad68b08
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.13.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/prettytable/prettytable/
+ https://pypi.org/project/prettytable/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # remove the implicit dep on coverage
+ sed -i -e '/coverage/d' pyproject.toml || die
+}